Package Details: python-astropy-healpix-doc 0.5-1

Git Clone URL: https://aur.archlinux.org/python-astropy-healpix.git (read-only, click to copy)
Package Base: python-astropy-healpix
Description: Documentation for AstroPy-HEALPix
Upstream URL: http://astropy-healpix.readthedocs.io/
Keywords: astronomy astropy science
Licenses: BSD
Submitter: Universebenzene
Maintainer: Universebenzene
Last Packager: Universebenzene
Votes: 1
Popularity: 0.000636
First Submitted: 2018-02-02 07:45
Last Updated: 2019-11-26 05:17

Latest Comments

Universebenzene commented on 2019-02-25 02:54

Hi @mboquien, I finally figure out that the error occurs when the python2-pytest-cov is installed. So I add a conditional in check() function. You can try it again :)

Universebenzene commented on 2019-02-24 16:42

@mboquien That's strange. I rebuild the package just now and I didn't meet this error while testing... Anyway you can just use the --nocheck option for makepkg to skip checking. Or feel free to comment or delete the check() function before building :)

mboquien commented on 2019-02-24 16:29

Hi. It gets further but now it fails with the following message:

pluggy.manager.PluginValidationError: Plugin 'pytest_cov' could not be loaded: (pytest 3.2.5 (/usr/lib/python2.7/site-packages), Requirement.parse('pytest>=3.6'))!

I think the error is the python2-pytest32 requirement. That being said, is it useful to run the tests for user's packages? I saw that more as a developer's tool who do not use packages. Thanks!

Universebenzene commented on 2019-02-23 11:53

Hi @mboquien, I made a patch to fix this DeprecationWarning, so you can try again. Thanks for feedback!

mboquien commented on 2019-02-23 10:05

Hello. This package does not appear to build because of deprecation warnings taken as errors:

E DeprecationWarning: np.asscalar(a) is deprecated since NumPy v1.16, use a.item() instead /usr/lib/python3.7/site-packages/numpy/lib/type_check.py:546: DeprecationWarning

This in turn prevents the installation of python-reproject, which in turns prevents the update of python-aplpy as it now depends on the former.

Thanks!