Package Details: python-aiohttp-gns3 2.3.10-1

Git Clone URL: https://aur.archlinux.org/python-aiohttp-gns3.git (read-only)
Package Base: python-aiohttp-gns3
Description: Asynchronous HTTP Client/Server for asyncio and Python
Upstream URL: https://aiohttp.readthedocs.io/
Licenses: Apache
Groups: gns3
Conflicts: python-aiohttp
Provides: python-aiohttp
Submitter: jnbrains
Maintainer: buzo
Last Packager: buzo
Votes: 11
Popularity: 0.946847
First Submitted: 2017-06-21 14:27
Last Updated: 2019-05-20 09:22

Required by (50)

Sources (1)

Latest Comments

buzo commented on 2018-09-12 09:16

I have downgraded this package to 2.3.9, since this is the version required by gns3-server.

jnbrains commented on 2018-08-09 15:32

Thanks stonyboy, Your help is much appreciated!

stonyboy commented on 2018-08-09 13:48

With the update to python 3.7 running GNS3 will give you an error:

... File "/usr/lib/python3.7/site-packages/aiohttp/init.py", line 6, in <module> from .client import * # noqa File "/usr/lib/python3.7/site-packages/aiohttp/client.py", line 15, in <module> from . import connector as connector_mod File "/usr/lib/python3.7/site-packages/aiohttp/connector.py", line 13, in <module> from . import hdrs, helpers File "/usr/lib/python3.7/site-packages/aiohttp/helpers.py", line 30 ensure_future = asyncio.async ^ SyntaxError: invalid syntax</module></module></module>

It turns out that the asyncio.async has been deprecated for the last couple of releases of python and has now finally been replaced with asyncio.ensure_future.

So if you want to run GNS3 with python 3.7 you need to patch the PKGBUILD file with something like this:

prepare() { cd ${_pkgname}-${pkgver} sed -i 's/yarl>=0.10.0,<0.11/yarl>=0.10.0,<=0.11/g' setup.py sed -i 's/asyncio.async/asyncio.ensure_future/' aiohttp/helpers.py }

jnbrains commented on 2017-12-06 09:05

Hi SinClaus,

It seems that 'python-aiohttp-135' package has been dropped from the AUR. Try to force remove it, even removing the 'gns3-server' package (it won't touch the server configurations, as they're kept in your home folder). And then install 'gns3-server' again from the AUR - it should pick up the correct dependencies.

SinClaus commented on 2017-12-06 01:49

:: python-aiohttp-gns3 and python-aiohttp-135 are in conflict (python-aiohttp). Remove python-aiohttp-135? [y/N] y

error: failed to prepare transaction (could not satisfy dependencies)

:: gns3-server: removing python-aiohttp-135 breaks dependency 'python-aiohttp-135'

:: python-aiohttp-cors-051: removing python-aiohttp-135 breaks dependency 'python-aiohttp-135'

==> WARNING: Your packages are saved in /tmp/yaourt-tmp-netmaster ==> Restart building python-aiohttp-cors-gns3 ? [y/N] ==> -------------------------------------------------

jnbrains commented on 2017-06-22 10:51

Hi hcartiaux,
I have reconsidered your suggestion and with a little tweak to your proposed
changes I've updated the package - allowing it to build against more recent
versions of yarl, yet keep the option of building with gns3 2x locked version.

Thanks.

jnbrains commented on 2017-06-22 00:08

Thanks, that's a neat trick.
But if we change the version requirements in this package alone, it'll
allow the possibility for yarl version conflict with gns3-server-git,
and we know there is an issue with gns3 2x and yarl 0.10 (api changes).

hcartiaux commented on 2017-06-21 18:30

You can avoid the specific python-yarl dependency with this prepare() function:

prepare() {
sed -i 's/yarl>=0.9.8,<0.10/yarl>=0.10.2,<0.11.0/g' ${srcdir}/${_pkgname}-${pkgver}/setup.py
}

If you add that, then I'll be able to upgrade the gns3-server PKGBUILD using your python-aiohttp-* PKGBUILDs.

Thank you