Package Details: python-agate-excel 0.2.5-2

Git Clone URL: https://aur.archlinux.org/python-agate-excel.git (read-only, click to copy)
Package Base: python-agate-excel
Description: Adds read support for Excel files (xls and xlsx) to agate
Upstream URL: https://agate-excel.readthedocs.org
Licenses: MIT
Submitter: gabrielmagno
Maintainer: alerque
Last Packager: alerque
Votes: 6
Popularity: 0.000011
First Submitted: 2016-07-08 16:56
Last Updated: 2021-08-16 19:25

Latest Comments

alerque commented on 2021-08-05 08:55

@izikeros You are correct that updating this is a fiasco. The issue is upstream, but I think we can still make packaging work. I thought I had a workaround in place, but given your error apparently it doesn't cover as many scenarios as I hoped.

I just overhauled the packaging with a different approach to getting around the upstream issue, see if it works for you now. The short version is that the issue is in the test suite, not the actual library, and by using a different test runner than they recommend I think we can sidestep the obsolete code.

izikeros commented on 2021-08-04 05:19

I cannot upgrade python-agate-excel 0.2.4-1 -> 0.2.4-2 because 0.2.4-2 requires python-parsedatetime<2.5 and I have already installed python-parsedatetime<2.6-3. Is it possible to bump-up in requirements python-parsedatetime to 2.6-3 or it introduces breaking changes and limitation <2.5 has justification?

hoistbypetard commented on 2021-07-27 12:25

@alerque Thanks! I'm glad I didn't spend time learning how to submit a patch to fix it the wrong way.

alerque commented on 2021-07-27 08:29

@hoistbypetard This package fell victim to an upstream issue whereby their test suite is not compatable with current package versions. See the commit I just made to work around the issue by disabling checks, and also this comment on python-agate-sql detailing why I did this for another user.

As for python-wheel it should not required. Nor should pip which apparently you have installed but is not listed as a dependency here. What is happening is the build system is detecting something it thinks is missing (in this case the outdated version of parsedatetime) and trying to go fetch and install it for you automatically behind the scenes. Any time you see pip/wheel errors in package builds it is likely because they are missing something else which they should have as a dependency. Most packages that list pip/wheel as a dependency do so incorrectly because they haven't found the real missing deps (a few actually use binary wheel builds from upstream, those are an exception).

hoistbypetard commented on 2021-07-26 18:57

This package now requires python-wheel to be installed. I don't know how to submit a patch to add that, but my last attempt at upgrading ended in an error stating that bdist_wheel was not found, and yay -S python-wheel fixed it.