Package Details: pyqt3 3.18.1-15

Git Clone URL: https://aur.archlinux.org/pyqt3.git (read-only, click to copy)
Package Base: pyqt3
Description: A set of Python bindings for the Qt3 toolkit
Upstream URL: http://www.riverbankcomputing.com/software/pyqt/intro
Keywords: qt
Licenses: GPL
Submitter: sergej
Maintainer: jose1711
Last Packager: jose1711
Votes: 11
Popularity: 0.000000
First Submitted: 2013-10-21 10:27
Last Updated: 2019-02-13 12:41

Latest Comments

applebloom commented on 2018-09-15 19:39

The package is not building any more with new versions of SIP. This is because SIP has completely removed support for Qt3 in 2016 (see "Removed all code generator support for PyQt3" in NEWS file).

So that makes this package unbuild-able with current SIP. The only way to bring it back would be to find or make a SIP fork/patchset.

Anyway, you can build this package now if you donwgrade the sip packages (python2-sip and sip) to version 4.18.1, the last one before pyqt3 support was removed. I confirmed this downgrade leads to successive build.

There might be a way to make this package functional again, but I don't know of one. I think it would take a lot of time and I don't currently have any. So I'm disowning this package.

qq736363980 commented on 2018-07-25 01:17

no make

applebloom commented on 2013-12-18 16:38

Adopted and fixed build.

sergej commented on 2013-10-21 10:27

removed from community