Package Details: pylote-git r186.981d39e-1

Git Clone URL: https://aur.archlinux.org/pylote-git.git (read-only, click to copy)
Package Base: pylote-git
Description: Software making it possible to draw on the screen of the computer, like handling various instruments of geometry.
Upstream URL: http://pascal.peter.free.fr/pylote.html
Licenses: GPL
Conflicts: pylote
Replaces: pylote
Submitter: flaviut
Maintainer: flaviut
Last Packager: flaviut
Votes: 3
Popularity: 0.000003
First Submitted: 2018-11-11 22:57
Last Updated: 2021-03-22 22:34

Latest Comments

Xavion commented on 2021-03-23 02:30

@flaviut:

I quite possibly am, and thanks for pointing that out. From memory, I did switch over to Yay after installing "pylote-git".

I have just done a "-Y --gendb", and that should fix it. The "--devel" flag will probably come in handy too. :-) The other thing is that I've been doing an "-Scc" after each "-Sua" (and that was wiping out Yay's cache).

Anyway, all in all, there's probably no need to add me as a co-maintainer. Thanks again for your help.

flaviut commented on 2021-03-23 00:24

yay -Syu has always worked fine for me, as far as I'm aware. Any chance you're running into https://github.com/Jguer/yay#i-know-my--git-package-has-updates-but-yay-doesnt-offer-to-update-it

But if you'd like managership, I can give you it as soon as I figure out how. I don't really use this package much.

Xavion commented on 2021-03-22 23:29

@flaviut: Yeah, I know -- I've been using Arch (and the AUR) since 2007. The problem is that AUR helpers (e.g. Yay) don't automatically detect upstream updates on Git packages (when you do an "-Sua"). That's why I/we need you to stay on the ball. :-)

flaviut commented on 2021-03-22 22:34

@Xavion the way that -git packages work, is that they pull the latest version of the software from git. The version number here is just a formality. The actual version number is dynamically calculated when you build the package.

I've gone ahead and bumped the version number (because why not) but it's certainly not required.

Xavion commented on 2021-03-20 21:12

Are you able to watch the repository and keep this package up-to-date? We're now up to r186.981d39e (i.e. v2.2).

flaviut commented on 2019-05-14 23:40

@bartus thanks, but all the credit (and blame :P) goes to the arch wiki: https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver()_function

It's fixed now though.

bartus commented on 2019-05-13 11:06

Nice pkgver, but you have to 'eat-up' stderr, otherwise makepkg will misinterpret the output (also you are missing git in makepends) https://pastebin.com/mqVJ2Yuu

flaviut commented on 2018-11-16 23:37

Sorry about that, everything is fixed in rev 2.

Xavion commented on 2018-11-16 23:24

There are some bugs in the files you've supplied.

Specifically, the paths are wrong in "/usr/bin/pylote" and "/usr/share/applications/pylote.desktop".

The result is that the application won't launch and its icon doesn't show up in the launcher. Well done.