Package Details: pyglossary 3.3.0-1

Git Clone URL: https://aur.archlinux.org/pyglossary.git (read-only, click to copy)
Package Base: pyglossary
Description: A tool for converting dictionary files aka glossaries with various formats for different dictionary applications
Upstream URL: https://github.com/ilius/pyglossary
Licenses: GPL3
Provides: pyglossary=3.3.0
Submitter: sikmir
Maintainer: sikmir
Last Packager: sikmir
Votes: 5
Popularity: 0.37
First Submitted: 2017-01-04 05:19
Last Updated: 2020-10-13 10:28

Latest Comments

pix3l commented on 2020-11-11 15:57

@homocomputeri

CRITICAL] Traceback (most recent call last): File "/usr/bin/pyglossary", line 6, in <module> main() File "/usr/lib/python3.8/site-packages/pyglossary/ui/main.py", line 503, in main from ui.ui_cmd import UI ModuleNotFoundError: No module named 'ui.ui_cmd'; 'ui' is not a package

  • -

pyglossary [ERROR] error while importing UI module: Traceback (most recent call last): File "/usr/lib/python3.8/site-packages/pyglossary/ui/main.py", line 516, in main import(f"ui.ui_{ui_type2}"), ModuleNotFoundError: No module named 'ui.ui_gtk'; 'ui' is not a package Traceback (most recent call last): File "/usr/lib/python3.8/site-packages/pyglossary/ui/main.py", line 516, in main import(f"ui.ui_{ui_type2}"), ModuleNotFoundError: No module named 'ui.ui_gtk'; 'ui' is not a packag

homocomputeris commented on 2020-11-08 16:39

pkgname=pyglossary
pkgver=4.0.0
pkgrel=1
pkgdesc="A tool for converting dictionary files aka glossaries"
arch=('any')
url="https://github.com/ilius/pyglossary"
license=('GPL3')
depends=(
  'python>=3.7'
  'python-lxml'
  'python-beautifulsoup4'
  'python-pyaml'
  'python-pyicu'
  'python-marisa'
  'libzim'
  'python-jinja'
  )
makedepends=('python-setuptools')
optdepends=(
  'gtk3: GTK3-based interface'
  'python-gobject: GTK3-based interface'
  'tix: Tkinter-based interface'
  'python-prompt_toolkit: interactive CLI'
  )
provides=("${pkgname}=${pkgver}")
source=("https://github.com/ilius/${pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('SKIP')

package() {
  cd "$srcdir/$pkgname-$pkgver"
  python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
  mkdir -p $pkgdir/usr/bin
  cp config.json $pkgdir/usr/share/pyglossary
}

m040601 commented on 2020-10-17 12:46

Getting this error trying to run it:

Traceback (most recent call last):
  File "/usr/bin/pyglossary", line 5, in <module>
    with open(join(dirname(__file__), "main.py")) as fp:
FileNotFoundError: [Errno 2] No such file or directory: '/usr/bin/main.py'

sikmir commented on 2020-10-13 10:28

Updated. Maintainer wanted.

m040601 commented on 2020-10-13 10:07

This PKGBUILD contains:

Conflicts:  pyglossary-git

There is no package called "pyglossary-git". Please remove it and also update the package, there have been releases in May 2020, https://github.com/ilius/pyglossary/releases