Package Details: pybitmessage 0.6.3.2-2

Git Clone URL: https://aur.archlinux.org/pybitmessage.git (read-only)
Package Base: pybitmessage
Description: Decentralized and trustless P2P communications protocol for sending encrypted messages to another person or to many subscribers
Upstream URL: https://github.com/Bitmessage/PyBitmessage
Keywords: bitmessage
Licenses: MIT
Conflicts: pybitmessage-git
Provides: pybitmessage
Submitter: klexx
Maintainer: None
Last Packager: TheLugal
Votes: 22
Popularity: 0.005544
First Submitted: 2015-10-30 20:17
Last Updated: 2018-12-20 11:35

Latest Comments

1 2 Next › Last »

dmp1ce commented on 2019-03-29 15:54

I'm getting "RuntimeError: the sip module implements API v12.0 to v12.5 but the PyQt4.QtCore module requires API v12.6"

Any suggestions?

kseistrup commented on 2019-01-27 12:09

Sorry, I flagged a wrong package.

g99 commented on 2018-12-21 20:35

python2-sip-pyqt4 solves the problem! Now we need a patch for checkdeps.py to make a user friendly statement like : "find required package at https://gitlab.com/inemum/inemum_archlinux/raw/master/python2-sip-pyqt4/PKGBUILD " else checkdeps.py might gain a reputation of being feckless.

tuxayo commented on 2018-12-20 14:51

See this about port to PyQt5 that would solve this if I understand correctly. https://github.com/Bitmessage/PyBitmessage/issues/897

TheLugal commented on 2018-12-20 11:35

I believe the reason pybitmessage broke is because there are no python2-sip-pyqt4, pybitmessage seems to run fine when I installed it. I've added it as a dependency. HOWEVER; this won't help until someone adds it to AUR/repos. Until then you'll have to install it yourself, or use inemum's handy PKGBUILD; https://gitlab.com/inemum/inemum_archlinux/raw/master/python2-sip-pyqt4/PKGBUILD

g99 commented on 2018-12-19 19:55

no longer builds, only this builds: https://aur.archlinux.org/packages/python2-pyqt4/

tuxayo commented on 2018-12-17 08:33

Since last days, it fails with the following message even though python2-sip is installed.

ImportError: No module named sip

deathsbreed commented on 2018-12-15 11:07

It seems bitmessage fails to run on my computer with an error about PyQt4:

2018-12-15 12:03:41,928 - CRITICAL - PyBitmessage requires PyQt unless you want to run it as a daemon and interact with it using the API. You can download it from http://www.riverbankcomputing.com/software/pyqt/download or by searching Google for 'PyQt Download' (without quotes).

Even though I currently have `python2-pyqt4 4.12.3-1' installed. I do believe there might've been an update to python2-pyqt4 or simply qt4 recently, though.

whoami commented on 2017-04-24 22:22

http://ix.io/rHY

imrehg commented on 2017-04-11 15:33

Looks like missing dependency (python2-msgpack):

ERROR: The msgpack package is not available. PyBitmessage requires msgpack.
ERROR: If your package manager does not have this package, try running "pip install msgpack-python".
CRITICAL: PyBitmessage cannot start. One or more dependencies are unavailable.