Package Details: purr-data 2.9.0.r4151.c01f8e7d-1

Git Clone URL: https://aur.archlinux.org/purr-data.git (read-only, click to copy)
Package Base: purr-data
Description: Jonathan Wilkes' nw.js variant of Pd-L2Ork (git version)
Upstream URL: https://agraef.github.io/purr-data/
Licenses: BSD
Conflicts: purr-data
Submitter: pure-aur
Maintainer: pure-aur
Last Packager: pure-aur
Votes: 4
Popularity: 0.000394
First Submitted: 2016-06-27 17:24
Last Updated: 2019-08-19 10:23

Dependencies (46)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3

aggraef commented on 2018-10-17 22:55

Well, @rokidakota, obviously you need to install these two packages from the AUR first. They both build fine for me. Or use my binary pacman repo (see link below), it has all the required deps readily available.

rokidakota commented on 2018-10-13 09:28

Hi, I'm now getting these errors:

error: target not found: libunicap
error: target not found: libsndobj-git
==> ERROR: 'pacman' failed to install missing dependencies.

helldrak commented on 2018-08-25 16:08

Hi everyone, Just to report some trouble with libunicap, which has been offline for a while. You can see the AUR comments (https://aur.archlinux.org/packages/libunicap) if that might help anyone building it. All the best,

morrisar47 commented on 2018-04-06 01:08

Thanks, it installed cleanly and appears to work just as before.

aggraef commented on 2018-04-04 16:00

Looking good, I've updated the PKGBUILD accordingly. @morrisar47 thanks for the heads up.

aggraef commented on 2018-04-04 14:09

@morrisar47 I'll have to check whether flite1 is still needed (if I remember correctly, it's required by one of the included externals).

morrisar47 commented on 2018-04-04 12:45

recent updates to purr-data won't install because of the flite1 dependency. It conflicts with flite, which is required by a lot of things. I'm able to install and use it by telling it to assume flite1 is already installed. Perhaps this could now be built against flite which was updated to 2.1-1 on 2018-01-16.

smoge commented on 2017-10-15 18:56

Looks like a simple tab/space python conflict in libsndobj-git's scons

ArchFae commented on 2017-09-22 09:34

Getting install errors on this package:

==> Finished making: purr-data 2.2.4.r3535.1f41004d-1 (Fri Sep 22 02:41:31 PDT 2017)
==> Cleaning up...
:: Installing purr-data package(s)...
:: purr-data package(s) failed to install.
:: ensure package version does not mismatch between .SRCINFO and PKGBUILD
:: ensure package name has a VCS suffix if this is a devel package

aggraef commented on 2016-06-27 17:31

This is Jonathan Wilkes' nw.js variant of Pd-L2Ork, nick-named "Purr-Data". Basically, it is Pd-L2Ork with the Tk GUI replaced with a JavaScript GUI implemented using nw.js (http://nwjs.io/).

This is the "stable" purr-data package, meaning that it will be updated less frequently, and ideally only after some testing.

Binary packages are available in the package repository at https://l2orkaur.bitbucket.io/. (Please follow the link for instructions on how to add the repo to your pacman.conf.)

The latest upstream source is available in the purr-data-git package: https://aur.archlinux.org/packages/purr-data-git/