Package Details: pup-git 1:0.4.0.r10.g681d7bb-1

Git Clone URL: https://aur.archlinux.org/pup-git.git (read-only, click to copy)
Package Base: pup-git
Description: Parsing HTML at the command line
Upstream URL: https://github.com/EricChiang/pup
Licenses: MIT
Conflicts: pup
Provides: pup
Submitter: awh
Maintainer: seiuneko
Last Packager: seiuneko
Votes: 16
Popularity: 0.34
First Submitted: 2014-09-13 19:26
Last Updated: 2021-01-08 11:45

Dependencies (2)

Required by (3)

Sources (1)

Latest Comments

« First ‹ Previous 1 2

awh commented on 2015-01-07 13:41

Updated with provides & conflicts (I believe that's the correct protocol for -git packages)

Jonhoo commented on 2015-01-06 22:42

Could you also add provides=('pup')?

Jonhoo commented on 2014-09-17 22:08

You will need to also increment the "epoch" of the package for upgrades to be visible to old users: https://wiki.archlinux.org/index.php/PKGBUILD#epoch

awh commented on 2014-09-16 18:18

Updated.

Jonhoo commented on 2014-09-16 17:59

Please increment epoch and transition to revision-counting as primary version as described in the VCS packaging guidelines (pkgver set to be `printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"`). The current scheme makes it very difficult to determine whether one version is newer than another.

awh commented on 2014-09-13 21:50

Oops. Fixed now, shouldn't have taken an exact copy from the wiki.

awh commented on 2014-09-13 21:38

Durr, nevermind. Saw the problem and have fixed it now.

awh commented on 2014-09-13 21:34

Yeah, I noticed that the package was pretty big.
I'm not very familiar with Go or its build system and just took an example from the wiki. What could I do to improve the packaging?

quite commented on 2014-09-13 19:58

You're installing too much. pacman -Ql pup-git
/src /pkg ?