Package Details: pulseaudio-modules-bt 1.4-3

Git Clone URL: https://aur.archlinux.org/pulseaudio-modules-bt.git (read-only, click to copy)
Package Base: pulseaudio-modules-bt
Description: PulseAudio Bluetooth modules with SBC, AAC, APTX, APTX-HD, Sony LDAC (A2DP codec) support
Upstream URL: https://github.com/EHfive/pulseaudio-modules-bt
Licenses: GPL3
Conflicts: pulseaudio-bluetooth, pulseaudio-modules-bt-git
Provides: pulseaudio-bluetooth, pulseaudio-modules-bt-git
Submitter: hayao
Maintainer: hayao
Last Packager: hayao
Votes: 13
Popularity: 4.98
First Submitted: 2020-04-14 12:08
Last Updated: 2020-10-08 06:17

Dependencies (11)

Required by (3)

Sources (2)

Pinned Comments

hayao commented on 2020-10-10 02:06

I'm just providing the package. Please report the bug of the module body upstream.

Latest Comments

OJFord commented on 2020-11-24 20:25

After upgrading to pulseaudio v14.0 and rebooting (i.e., presumably, restarting pulseaudio.service) it seemed to be necessary to reinstall pulseaudio-modules-bt.

At the same version, just reinstalling the latest v1.4-3 that I already had cached.

Prior to that I was unable to connect a bluetooth headset: 'Protocol not available'; module-bluetooth-{discover,policy} were not loaded, and nor did loading them myself resolve it.

tleydxdy commented on 2020-10-10 02:38

hmm, so the fix was just removing the device and adding it back again. Welp. It happened between 1.4-1 and 1.4-3 so I thought it had something to do with the packaging.

hayao commented on 2020-10-10 02:06

I'm just providing the package. Please report the bug of the module body upstream.

tleydxdy commented on 2020-10-10 01:57

All the codecs (aptx, ldac, etc) shows as unavaliable after update. only HSP/HFP is useable. pulseaudio doesn't show any error other than

W: [pulseaudio] module-bluez5-device.c: Refused to switch profile to a2dp_sink_ldac: Not connected

switching profile in blueman gives

Failed to change profile to a2dp_sink_ldac

jonathon commented on 2020-10-08 10:04

Just for info (very minor, not worth a new pkgrel), this package does not need to provide/conflict pulseaudio-modules-bt-git - it's up to the -git package to provide/conflict with this one.

jonathon commented on 2020-10-06 20:52

Does this need bumping for pulseaudio 13.99.2?

diff --git a/PKGBUILD b/PKGBUILD
index c0ec0bf..506360b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@

 pkgname=pulseaudio-modules-bt
 pkgver=1.4
-pulseaudio_ver=13.99.1
-pkgrel=1
+pulseaudio_ver=13.99.2
+pkgrel=2
 pkgdesc="PulseAudio Bluetooth modules with SBC, AAC, APTX, APTX-HD, Sony LDAC (A2DP codec) support"
 arch=("i686" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
 url="https://github.com/EHfive/pulseaudio-modules-bt"
@@ -19,7 +19,8 @@ conflicts=("pulseaudio-bluetooth" "pulseaudio-modules-bt-git")
 source=("https://github.com/EHfive/pulseaudio-modules-bt/archive/v${pkgver}.zip"
         "https://github.com/pulseaudio/pulseaudio/archive/v${pulseaudio_ver}.zip")

-md5sums=('711a7f930321e56706acdb441de0e432' 'a0af6ae3ad144a11393c5d0cdbcd2951')
+b2sums=('845489e1dda12afd270bd63292b83a3fedd6508c1f2b35de8b748fd91f876e8c14109d5c97d5cd1af65157ca684fc4ef95688a9851df2248ac197d3bbe5bb09d'
+        'fde7ec065e9bce353392316cda8894533ddf374270de18dd6e980f856b2850f5449c3bc2106f0e4788c2dc28b85654fc9e2b0712476f055ae6551283c063e575')

 prepare() {
     cd "$srcdir/pulseaudio-modules-bt-${pkgver}"

agm28011997 commented on 2020-06-07 15:51

https://github.com/EHfive/pulseaudio-modules-bt/issues/115