Package Details: pulseaudio-git 14.0.r271.g1a194c991-1

Git Clone URL: https://aur.archlinux.org/pulseaudio-git.git (read-only, click to copy)
Package Base: pulseaudio-git
Description: A featureful, general-purpose sound server (development version)
Upstream URL: http://pulseaudio.org/
Licenses: GPL, LGPL
Conflicts: libpulse-mainloop-glib.so, libpulse-simple.so, libpulse.so, pipewire-pulse, pulse-audio-jack, pulseaudio-bluetooth, pulseaudio-equalizer, pulseaudio-lirc, pulseaudio-zeroconf
Provides: libpulse, libpulse-mainloop-glib.so, libpulse-simple.so, libpulse.so, pulseaudio, pulseaudio-bluetooth, pulseaudio-equalizer, pulseaudio-jack, pulseaudio-lirc, pulseaudio-zeroconf
Submitter: None
Maintainer: SolarAquarion
Last Packager: SolarAquarion
Votes: 41
Popularity: 0.043316
First Submitted: 2009-02-09 14:33
Last Updated: 2021-04-08 17:11

Dependencies (46)

Required by (1000)

Sources (2)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Werkov commented on 2021-04-19 07:57

FTR, I confirm that valgrind and libwrap dependencies are still needed when building (as of pkgver=14.0.r274.gfec9eb178).

Additionally, the build requires doxygen (I'd prefer to disable docs build, however, I wasn't able to find a PA toggle for that).

tywyqu commented on 2021-04-07 13:04

succeeded to install after removing "lelogid" from build config:

sed -i -e 's/\-lelogind//' ./build/build.ninja

PythonNut commented on 2021-02-26 00:26

Even after installing libelogind, I run into the following linker error:

FAILED: src/modules/module-systemd-login.so
cc  -o src/modules/module-systemd-login.so src/modules/module-systemd-login.so.p/module-systemd-login.c.o -flto -Wl,--as-needed -Wl,--allow-shlib-undefined -shared -fPIC -Wl,--start-group -Wl,-soname,module-systemd-login.so -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now '-Wl,-rpath,$ORIGIN/../pulse:$ORIGIN/..:$ORIGIN/../pulsecore' -Wl,-rpath-link,/home/pythonnut/.cache/paru/clone/pulseaudio-git/src/build/src/pulse -Wl,-rpath-link,/home/pythonnut/.cache/paru/clone/pulseaudio-git/src/build/src -Wl,-rpath-link,/home/pythonnut/.cache/paru/clone/pulseaudio-git/src/build/src/pulsecore src/pulse/libpulse.so.0.23.0 src/libpulsecommon-14.0.so src/pulsecore/libpulsecore-14.0.so -Wl,-z,nodelete -Wl,--no-undefined -pthread /usr/lib/libsystemd.so -L/lib -lelogind -Wl,--end-group
/usr/bin/ld: cannot find -lelogind
collect2: error: ld returned 1 exit status

nika commented on 2021-02-22 15:13

Seems like libelogind should be added as dep

pulseaudio/meson.build:658:0: ERROR: Dependency "libelogind" not found, tried pkgconfig and cmake

sentriz commented on 2021-02-12 23:44

seems like I had to install valgrind and libwrap before installing. perhaps they should be added as deps?

professed commented on 2021-01-20 17:39

@beroal: Thank you, this is good to know for the future. For now, the updated version of pulseaudio in the official repo now seems to work with my system, so I've uninstalled the AUR package.

beroal commented on 2021-01-20 10:29

@professed You can upgrade with --nodeps. This may break database consistency. Then check database consistency with -D --check.

professed commented on 2021-01-20 09:03

I'm on Manjaro GNOME and I cannot perform the latest stable update (2021-01-19) due to a tricky package conflict pulseaudio-git, which I need for hardware support. I get the following message when attempting 'pacman -Syu':

looking for conflicting packages...
:: libpulse and pulseaudio-git are in conflict (libpulse.so). Remove pulseaudio-git? [y/N]

Declining to remove pulseaudio-git aborts the upgrade ("error: unresolvable package conflicts detected"), and opting to remove it also causes the update to error out with the following dependency errors:

error: failed to prepare transaction (could not satisfy dependencies)
:: removing pulseaudio-git breaks dependency 'pulseaudio-bluetooth' required by gnome-bluetooth
:: removing pulseaudio-git breaks dependency 'pulseaudio-bluetooth' required by manjaro-bluetooth
:: removing pulseaudio-git breaks dependency 'pulseaudio-equalizer' required by manjaro-pulse
:: removing pulseaudio-git breaks dependency 'pulseaudio-jack' required by manjaro-pulse
:: removing pulseaudio-git breaks dependency 'pulseaudio-zeroconf' required by manjaro-pulse
:: removing pulseaudio-git breaks dependency 'pulseaudio-lirc' required by manjaro-pulse

I can't temporarily remove any of the packages that require pulseaudio-git, either, as they're required by yet other packages, which are required by yet other packages.

Attempting to install vanilla pulseaudio in place of pulseaudio-git is also a non-starter, as it yields the same initial error message as above ("libpulse and pulseaudio-git are in conflict (libpulse.so).", etc.).

Any help climbing out of this rabbit hole would be greatly appreciated.

professed commented on 2020-12-10 20:05

Update: Installing the valgrind package prior to build solves the dependency problem and allows for a successful install. Suggest adding it to the list of dependencies.

professed commented on 2020-12-09 19:54

Build of pulseaudio-git 14.0.r41.g6bf178d79-1 fails, erroring out with the following message:

pulseaudio/meson.build:234:6: ERROR: C header 'valgrind/memcheck.h' not found

A full log can be found at /home/username/.cache/yay/pulseaudio-git/src/build/meson-logs/meson-log.txt
==> ERROR: A failure occurred in build().
    Aborting...
error making: pulseaudio-git

The meson log file mentioned in the output above is here in the event it's helpful.