Package Details: pulse-secure 9.1r9.0_b255-1

Git Clone URL: https://aur.archlinux.org/pulse-secure.git (read-only, click to copy)
Package Base: pulse-secure
Description: Pulse Connect Secure (PCS) Client
Upstream URL: https://www.pulsesecure.net/
Licenses: custom
Conflicts: pulse-connect-secure
Submitter: yan12125
Maintainer: chiwanpark
Last Packager: chiwanpark
Votes: 24
Popularity: 2.39
First Submitted: 2017-09-02 07:40
Last Updated: 2020-11-12 11:33

Pinned Comments

yan12125 commented on 2018-10-30 11:41

You need to rebuild webkitgtk if you got ICU related errors.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

thecrow commented on 2021-01-26 12:59

@chiwanpark,@je-vv Podeis actualizar la información que solicitan desde el foro de pulse secure, para replicar el problema con curl 7.74

je-vv commented on 2021-01-23 22:56

@chiwanpark, although 9.1R10 does not fix the curl related segfault, I see it positive if you update the package any ways. Thanks a lot !

je-vv commented on 2021-01-23 22:53

BTW, on all 3 posts under the pulse-secure comuniy forum where I'm involved, the answer is always to get a big shot on business relations with pulse-secure, to get in contact with them. So I guess there won't be any support from pulse-secure to final users on the issues their own SW generates. There's NO way to reach out to their devs or support team. I don't have any alternative, given the company where I work chose pulse-secure and uses MFA even requiring its GUI, which depends on obsolete and insecure webkitgtk.

I guess the work around with curl-pulse-secure is all there will be, until everything starts segfaulting on other platforms with more users, like redhat derivatives and debian/ubuntu derivatives, which can influence big shots from IT making business with them. That's to be expected from closed source SW I'd guess... How disappointing !!

tryax commented on 2021-01-21 09:46

/pulseUi: error while loading shared libraries: libicui18n.so.67: cannot open shared object file: No such file or directory

lib32-icu has been updated to 68.2-1, so pulse can't find version 67?

chiwanpark commented on 2021-01-19 15:46

@je-vv: the 9.1R10 does not fix the curl related crash. I guess that the user posting 9.1R10 works with curl 7.74 in Ubuntu did test with OpenSSL < 1.1.0. I've posted the question about OpenSSL version to the forum.

https://community.pulsesecure.net/t5/Pulse-Desktop-Clients/Linux-Pulse-Client-does-not-work-with-curl-7-74/m-p/44607/highlight/true#M2253

chiwanpark commented on 2021-01-19 15:41

@je-vv and other users: I've packaged the new 9.1R10 client. However, in my testing environment host checker does not work properly. Thus, I didn't upload the package to AUR repository. But I request for someone to test the package. (You need to install curl 7.73 to run this package)

https://drive.google.com/file/d/1FbcwS1keRbT2L4hFMBX51tTvCWqkp07j/view?usp=sharing

Any reports are welcome.

chiwanpark commented on 2021-01-19 10:59

@je-vv I'm trying to upgrade this package to the 9.1R10 release, but it takes more time than the previous version. In 9.1R10, Pulse Secure client are totally rewritten.

je-vv commented on 2021-01-18 21:08

@chiwanpark and @yan12125, according to https://community.pulsesecure.net/t5/Pulse-Desktop-Clients/Linux-Pulse-Client-does-not-work-with-curl-7-74/m-p/44599/highlight/true#M2249, latest version of 9.1R10 should have fixed the curl issue, and then curl-pulse-secure wouldn't be needed... Can you please upgrade?

bakgwailo commented on 2021-01-15 20:35

@andrea.denisse @hedin504

edit: nevermind, fixed the segfault by installing the curl-pulse-secure AUR package.

microdou commented on 2021-01-11 13:41

Using curl-pulse-secure is the best solution. Don't use soft link!