Package Details: pueue 0.8.2-1

Git Clone URL: https://aur.archlinux.org/pueue.git (read-only, click to copy)
Package Base: pueue
Description: A command scheduler for shells
Upstream URL: https://github.com/nukesor/pueue
Licenses: MIT
Submitter: Nukesor
Maintainer: Nukesor
Last Packager: Nukesor
Votes: 8
Popularity: 3.09
First Submitted: 2017-02-14 21:31
Last Updated: 2020-11-28 22:14

Latest Comments

Nukesor commented on 2020-11-13 18:22

Damn.

I actually didn't notice. One of the dependencies broke backward-compatibility to any Rust version <1.42, since it uses a new language feature.

Well... I guess Pueue now no longer compiles on Rust <1.42 -.- Please update via rustup update if you run in this error. v1.42 is considered stable at this point.

Another possibility would be to install the pueue-bin package.

dadav commented on 2020-11-13 16:55

I'm getting an error while it compiles "crossterm":

error[E0658]: use of unstable library feature 'matches_macro' --> /home/xxx/.cargo/registry/src/github.com-1ecc6299db9ec823/crossterm-0.18.1/src/event/filter.rs:16:9 | 16 | matches!(*event, InternalEvent::CursorPosition(, )) | ^^^^^^^ | = note: for more information, see https://github.com/rust-lang/rust/issues/65721 = help: add #![feature(matches_macro)] to the crate attributes to enable

EDIT// Ok, I uninstalled rustup and then it worked :)

Nukesor commented on 2020-10-20 20:13

@flipee The PKGBUILD should now be fixed :) I wasn't aware that a shared SRCDEST is a possible scenario. Thanks for the report!

flipee commented on 2020-10-20 17:28

Please prepend the source line with $pkgname-$pkgver.tar.gz::. The SRCDEST directory can be the same for all packages.

Svenstaro commented on 2020-02-02 01:24

This is a bin package and should be suffixed with -bin. In Arch we generally prefer to build stuff from source and so this package should try to do that as well using cargo build --release --locked.

hvksmr1996 commented on 2020-02-01 01:22

since I also deploy shell completion scripts and the service file

They are all in utils folder, correct? If so, you can save user's bandwidth by also pack them into an archive (utils.tar.gz), release that archive to GitHub release page, and add the archive to source array in PKGBUILD.

Nukesor commented on 2020-01-31 15:46

My fault. I used the pueue-git as a template and forgot to remove the makedepends.

The tar.gz however is needed, since I also deploy shell completion scripts and the service file. Those are only present in the source code.

hvksmr1996 commented on 2020-01-31 14:35

This PKGBUILD installs prebuilt binaries, why does it still have makedepends=(git cargo) and <https://github.com/Nukesor/pueue/archive/v>${pkgver}.tar.gz?

Nukesor commented on 2020-01-22 13:07

Issue is fixed. Sorry for the inconvenience, I accidentally renamed a path that has been changed upstream but isn't yet included in the current version.

gdmsl commented on 2020-01-22 13:02

Hi, I cannot build the package. It gives me this error:

install: cannot stat 'utils/pueued@.service': No such file or directory