Package Details: projectm-git 1606.8f442c5b-1

Git Clone URL: https://aur.archlinux.org/projectm-git.git (read-only)
Package Base: projectm-git
Description: Music visualizer which uses 3D accelerated iterative image based rendering (git version)
Upstream URL: https://github.com/projectM-visualizer/projectm
Licenses: LGPL
Conflicts: projectm
Provides: projectm
Submitter: punkrockguy318
Maintainer: punkrockguy318
Last Packager: punkrockguy318
Votes: 2
Popularity: 0.054638
First Submitted: 2017-09-22 17:39
Last Updated: 2018-09-04 15:19

Required by (15)

Sources (1)

Latest Comments

1 2 3 Next › Last »

mrturcot commented on 2019-03-02 20:48

After this commit was added projectm-git is now building :) https://github.com/projectM-visualizer/projectm/commit/0378ee77eee4934d4fe3309effa648c488daa939

FYI you dont need the "--enable-qt" flag for projectm-puslseaudio, it now checks if needed packages are installed and will build with necessary flags.

==> Finished making: projectm-git 1778.0378ee77-1 (Sat 02 Mar 2019 12:38:26 PM PST)

mrturcot commented on 2019-03-01 18:03

No still not building but thanks! Looks like they need to fix upstream build errors. https://travis-ci.org/projectM-visualizer/projectm

Build is stuck here now.

Unknown option 'Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now'.  
make[4]: *** [Makefile:795: qprojectm_mainwindow_moc.cpp] Error 1

cyber commented on 2019-03-01 09:20

Does this help: https://github.com/projectM-visualizer/projectm/commit/8cafafab65263be4aa85591f7ce19f8345830057 ?

mrturcot commented on 2019-02-28 22:34

Hey @punkrockguy318 my build failed today with "--enable-qt", also failed with default PKGBUILD (Same error). I believe its to due with https://github.com/projectM-visualizer/projectm/commit/5598b8377cb7a52a9624bc7c305c7edf10047754

Makefile: qt / jack / pulseaudio (#163)  
Major updates to Makefiles, please report any build time issues!  
Adding/updating makefiles for Qt, Jack, and Pulseadio implementations

My Error

Making all in projectM-qt  
make[3]: Entering directory '/home/mrturcot/projectm-git/src/projectm/src/projectM-qt'  
uic-qt5 -qt=5 -o ui_qprojectm_mainwindow.h qprojectm_mainwindow.ui  
uic-qt5 -qt=5 -o ui_qpreseteditordialog.h qpreseteditordialog.ui  
uic-qt5 -qt=5 -o ui_qprojectmconfigdialog.h qprojectmconfigdialog.ui  
Unknown option 'qt'.  
Unknown option 'qt'.  
Unknown option 'qt'.

Thanks for maintaining this package! I need my bleeding edge visualisations lol :)

punkrockguy318 commented on 2018-09-04 16:03

Thanks for the report and yeah I was being a dick - especially the ellipsis

Sorry

michaelnix commented on 2018-09-04 16:01

Oh I read. I was simply reporting. No need to be a dick.

punkrockguy318 commented on 2018-09-04 15:26

Thanks cyber - I'll catch up in IRC/Github when I get a chance

punkrockguy318 commented on 2018-09-04 15:25

@michaelnix if you were to read before commenting, you would see that I have offered this package up for adoption.....

cyber commented on 2018-09-04 15:25

Hey thanks! There is support for the qt5/pulseaudio app. There is a new version coming out shortly that improves the openGL/ES support quite a bit. If you let us know of any issues, such as what you experienced with the pulseaudio application, a ticket would be most appreciated. Thanks again!

punkrockguy318 commented on 2018-09-04 15:22

Thanks for the heads up. I've updated this package to work with the autotools-based build found the github repo.

I've dropped all of the "application" packages since upstream has dropped most of these from the build system for the time being. I hope that this is just a transition-phase and they will eventually support these applications within the build system.

The new autotools system has a flag for "--enable-qt" that for some reason builds a "projectM-pulseaudio" binary - but this did not seem to work at all so I have not included it in this package.

This package includes the projectm.so and a projectMSDL binary

I'm very happy to see upstream projectM activity, but be aware that everything is very experimental right now and I don't believe much works outside of the SDL2 test client