Package Details: private-internet-access-vpn 3.3.3-12

Git Clone URL: https://aur.archlinux.org/private-internet-access-vpn.git (read-only, click to copy)
Package Base: private-internet-access-vpn
Description: Installs VPN profiles for Private Internet Access Service
Upstream URL: https://www.privateinternetaccess.com/
Keywords: connman networkmanager openvpn python vpn
Licenses: GPL
Submitter: flamusdiu
Maintainer: flamusdiu
Last Packager: flamusdiu
Votes: 85
Popularity: 0.39
First Submitted: 2014-08-14 01:22
Last Updated: 2019-11-25 03:37

Pinned Comments

flamusdiu commented on 2016-10-01 10:56

Dev version -> https://aur.archlinux.org/packages/private-internet-access-vpn-dev/

You can submit issues on Github -> https://github.com/flamusdiu/python-pia

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

ZAKhan commented on 2018-04-22 16:46

Not work :(

Cavsfan commented on 2018-04-15 22:47

Thanks kleshas! Worked great on brand new install! :-)

kleshas commented on 2018-03-20 20:58

The three that fail for me are ip-lport-3.3.3-5.zip (openvpn-ip-lport.zip), default-3.3.3-5.zip (openvpn.zip), strong-3.3.3-5.zip (openvpn-strong.zip) (in order as below).

If you want it to work now, enter these three SHA256sums into the top three in the PKGBUILD (say yes to editing PKGBUILD on install):

697cdc812c5cf1d7ee694e4b0dc447846c9de08b43e2fe3f4c24448a81a2c5f7

6f899ff3a040be09499c90091f1f91859487ab176c54c610f6d4be2c74e5f32f

084feed448cba46230ee572174d732bf05f541c52e2b995914b9063485100806

To get these, I downloaded them from the list on this page under the Sources (10) area, then ran sha256sum on them.

flamusdiu commented on 2018-03-19 10:29

I am aware of it. PIA updated the zips again. It will be a few days for me to update it due to RL stuff.

slothrop commented on 2018-03-18 12:33

I'm having the same issue, zip files do not pass the validity check (not using any packaging manager for AUR):

==> Validating source files with sha256sums... ip-lport-3.3.3-5.zip ... FAILED default-3.3.3-5.zip ... FAILED strong-3.3.3-5.zip ... FAILED login-example.conf ... Passed pia-example.conf ... Passed restart.conf ... Passed vpn.sh ... Passed pia.8.gz ... Passed python-pia ... Skipped openvpn-update-resolv-conf ... Skipped ==> ERROR: One or more files did not pass the validity check!

justinnichols commented on 2018-03-14 21:13

Occurred again:

==> Validating source files with sha256sums... ip-lport-3.3.3-5.zip ... FAILED default-3.3.3-5.zip ... FAILED strong-3.3.3-5.zip ... FAILED login-example.conf ... Passed pia-example.conf ... Passed restart.conf ... Passed vpn.sh ... Passed pia.8.gz ... Passed python-pia ... Skipped openvpn-update-resolv-conf ... Skipped ==> ERROR: One or more files did not pass the validity check! ==> ERROR: Makepkg was unable to build private-internet-access-vpn.

Det commented on 2018-01-30 13:08

https://wiki.archlinux.org/index.php/PKGBUILD#Sources source=('unique_package_name::file_uri')

flamusdiu commented on 2018-01-25 20:15

@bramswenson: I don't have any issue when using aura and the way it caches packages. Technically, it's pacaur way of caching. Either way, changed the PKGBUILD. I update the pkgrel everytime the PIA changes the zip for one reason or another.

@tom.swartz07: Yeah, I knew about that. Thanks for the link to refresh my memory.

tom.swartz07 commented on 2018-01-25 00:13

The files that are conflicting should be updated to use the alternative uri path:

https://wiki.archlinux.org/index.php/PKGBUILD#Sources source=('unique_package_name::file_uri')

bramswenson commented on 2018-01-22 15:44

This build script should not require end users to remove cached packages. It should download the packages with the version name in the downloaded file name. You can do this with the correct formatting of source array entries. This would download the files with some unique id rather than having the same name for every version. Problem solved. Please update your PKGBUILD file so users don't have to repair it manually each time. This is within your power.