Package Details: praat 6.1.03-1

Git Clone URL: https://aur.archlinux.org/praat.git (read-only, click to copy)
Package Base: praat
Description: Doing Phonetics by computer (speech analysis)
Upstream URL: http://www.fon.hum.uva.nl/praat/
Licenses: GPL
Conflicts: praat-bin, praat-git
Submitter: jpate
Maintainer: svkampen
Last Packager: svkampen
Votes: 23
Popularity: 0.000000
First Submitted: 2010-03-09 18:13
Last Updated: 2019-09-03 12:44

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

grausichel commented on 2014-11-19 22:33

There is again a new version (9 November 2014), which requires an update of the PKGBUILD:

pkgver=5.4.01
source=("http://www.fon.hum.uva.nl/praat/praat5401_sources.tar.gz")
md5sums=('92019d42037d3daf7bb8407f3fe02d2d')

Change the directory paths from "$srcdir/sources_5400/" to "$srcdir/sources_5401/"

grausichel commented on 2014-11-19 22:32

There is again a new version (9 November 2014), which requires an update of the PKGBUILD:

pkgver=5.4.01
source=("www.fon.hum.uva.nl/praat/praat5401_sources.tar.gz")
md5sums=('92019d42037d3daf7bb8407f3fe02d2d')

Change the directory paths from "$srcdir/sources_5400/" to "$srcdir/sources_5401/"

mwv commented on 2014-07-09 17:42

For the new (July 2nd, 2014) version, change this in the PKGBUILD:

pkgver=5.3.81
source=("http://www.fon.hum.uva.nl/praat/praat5381_sources.tar.gz")
md5sums=('f3ce934a5e4d3b161d179a9666196431')

and every 5376 -> 5381.

mimex commented on 2014-05-13 16:11

For the last version you can change this in the PKGBUILD:

pkgver=5.3.76
url=("http://www.fon.hum.uva.nl/praat/praat5376_sources.tar.gz")
md5sums=('43f41ca761d357045c2196d0ccfcfa71')

Change every 5369 with 5376.

mimex commented on 2014-05-13 16:08

For the last version you can change this in the PKGBUILD:

pkgver=5.3.76
url=("http://www.fon.hum.uva.nl/praat/praat5376_linux64.tar.gz")
md5sums=('43f41ca761d357045c2196d0ccfcfa71')

Change every 5369 with 5376.

Amnet04 commented on 2014-03-31 13:30

And sorry, this is the line for the source:
source=("http://www.fon.hum.uva.nl/praat/praat5369_sources.tar.gz")

Amnet04 commented on 2014-03-31 13:29

I dont know about the correct procedure, but here is the pkgbuild for version 5.3.69:

# Maintainer: jpate <j.k.pate@sms.ed.ac.uk>
pkgname=praat
pkgver=5.3.69
pkgrel=1
pkgdesc="A tool for 'Doing Phonetics by computer'"
arch=('x86_64' 'i686')
url="http://www.fon.hum.uva.nl/praat/"
license=('GPL')
depends=( 'alsa-lib' 'gtk2' )
makedepends=( 'pkg-config' )
optdepends=( 'ttf-sil-fonts' )
source=("http://www.fon.hum.uva.nl/praat/praat5356_sources.tar.gz")
md5sums=('30793d2f623ea4532df87e41105cacf6')

prepare() {
cd "$srcdir/sources_5369/"

cp makefiles/makefile.defs.linux.alsa makefile.defs

sed -i 's/-lasound/-lasound -lpthread/' makefile.defs
}

build() {
cd "$srcdir/sources_5369/"

make
}

package() {
cd "$srcdir/sources_5369/"

install -Dm755 praat "$pkgdir/usr/bin/praat"
}

parchd commented on 2014-03-19 10:59

There is also a version 5.3.66 now. The existing PKGBUILD works fine if you replace every 5356 with 5366 and put the correct md5sum in (d7d36a2e61043fcffeee603fd5ffeec7)

Shardz commented on 2014-01-21 22:13

Here's a PKGBUILD for the latest version: http://dl.logik.li/praat-5.3.62-PKGBUILD

Xyne commented on 2013-09-27 00:40

Hi,

The package should be updated to conform to current package guidelines. The sed command should be in a "prepare" function and the make command should be in a "build" function.

Thanks!