Package Details: pqiv 2.11-3

Git Clone URL: https://aur.archlinux.org/pqiv.git (read-only, click to copy)
Package Base: pqiv
Description: Modern rewrite of Quick Image Viewer
Upstream URL: https://github.com/phillipberndt/pqiv
Keywords: graphics
Licenses: GPL3
Submitter: Carpetsmoker
Maintainer: caleb
Last Packager: caleb
Votes: 12
Popularity: 0.92
First Submitted: 2015-08-20 10:37
Last Updated: 2020-04-10 15:31

Latest Comments

caleb commented on 2020-04-10 15:31

@padv I definitely follow your logic there, but at the same time those optdepends are invalid: in the context on a repository hosting this package those are not things you can install in order to get access to optional features, they have to be present at build time. It won't do people a bit of good to install those packages even before they install this because it's a matter of what the build machine has and what flags are enabled on ./configure.

I've gone ahead and dropped video & PDF support, but I'm torn over whether that's actually the right thing to do. We can't all have it our own way and it seems like erring on the side of including more upstream features rather than less would be the way to go.

padv commented on 2020-04-09 23:15

Pqiv is an image viewer and should only try to view images, doesn't make sense to build with video support since its very limited and better handled by other video viewers. Also disabled PDF support since it only shows first page of multipage PDF this is better handled with a PDF viewer, here is my changed new PKGBUILD:

diff --git a/PKGBUILD b/PKGBUILD
index 258199c..a60a048 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,24 @@

 pkgname=pqiv
 pkgver=2.11
-pkgrel=2
+pkgrel=3
 pkgdesc='Modern rewrite of Quick Image Viewer'
 arch=('x86_64' 'i686')
 url="https://github.com/phillipberndt/$pkgname"
 license=('GPL3')
-depends=('ffmpeg'
-         'gtk3'
+depends=('gtk3'
          'imagemagick'
          'libarchive'
          'libspectre'
-         'libwebp'
-         'poppler-glib')
+         'libwebp')
+optdepends=('ffmpeg: video support'
+            'poppler-glib: PDF support')
 source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
 sha256sums= ('ea1f8b6bcb58dee19e2d8168ef4efd01e222c653eabbd3109aad57a870cc8c9b')

 build() {
        cd "$pkgname-$pkgver"
-    ./configure
+    ./configure --without-libav --without-poppler
        make
 }

LiteracyFanatic commented on 2020-04-02 17:34

OK, that makes sense. Thanks for the quick response.

caleb commented on 2020-04-02 17:12

@LiteracyFanatic It's not quite that simple, because then when I build it such as when I do to host it in my package repository it will be an invalid package that crashes on install because it doesn't have the dependencies it needs to actually run. But I agree the current setup is less than ideal too: it isn't clear that the optdepends have to be present at compile time instead of runtime. I think the only thing I can do is just enable the other backends and move the optdepends to be full fledged dependencies.

LiteracyFanatic commented on 2020-04-02 16:20

Would you consider removing the --backends flag from the call to ./configure? This way it will automatically build with support for whichever backends the user has installed. This way, for example, pqiv will work with webp images as long as libwebp is already installed.

caleb commented on 2018-08-10 12:00

Thanks @padv, I've adopted this and updated is per your comment (as well as to the latest upstream version).

padv commented on 2017-08-15 22:45

Should depend on libarchive for images in compressed archives:

--- PKGBUILD 2017-08-16 00:37:59.345933151 +0200
+++ PKGBUILD.new 2017-08-16 00:40:26.825138535 +0200
@@ -2,13 +2,15 @@

pkgname=pqiv
pkgver=2.9
-pkgrel=1
+pkgrel=2
pkgdesc="Modern rewrite of Quick Image Viewer"
arch=('i686' 'x86_64')
url="https://github.com/phillipberndt/pqiv/"
license=('GPL3')
-depends=('gtk3') # Also works with GTK2...
+depends=('gtk3' # Also works with GTK2...
+ 'libarchive>=3.3.2') # for images in compressed archives, 3.3.2 fixes https://github.com/libarchive/libarchive/issues/869
optdepends=(
+'ffmpeg: video support'
'libspectre: PS/EPS support'
'poppler: PDF support'
'libwebp: WebP support'
@@ -20,6 +22,7 @@

build() {
cd $pkgname-$pkgver
+ ./configure --backends=archive,gdkpixbuf
make
}