Package Details: postman 7.8.0-1

Git Clone URL: https://aur.archlinux.org/postman.git (read-only)
Package Base: postman
Description: Build, test, and document your APIs faster
Upstream URL: https://www.getpostman.com/downloads/
Keywords: api document postman
Licenses: custom:Postman EULA
Conflicts: postman-bin
Provides: postman
Submitter: kitsunyan
Maintainer: bruceutut
Last Packager: bruceutut
Votes: 29
Popularity: 1.855030
First Submitted: 2018-01-29 15:58
Last Updated: 2019-09-27 10:19

Dependencies (1)

Required by (0)

Sources (4)

Pinned Comments

bruceutut commented on 2019-06-28 00:34

Hey gus. I just update this package to use community/electron4 package as dependency. This update will reduce the package size 100M around.

(Currently not runing under electron 5.x or above)

PS. Please disable self update in settings manually.

Latest Comments

1 2 Next › Last »

bruceutut commented on 2019-06-28 00:34

Hey gus. I just update this package to use community/electron4 package as dependency. This update will reduce the package size 100M around.

(Currently not runing under electron 5.x or above)

PS. Please disable self update in settings manually.

bendavis78 commented on 2019-03-18 17:48

Are there any workarounds to the libhttp_parser issue?

ItachiSan commented on 2019-03-18 12:52

Hey everyone; I've contacted one of the maintainers of the official electron packages for ArchLinux and asked a bit of help backporting Electron 1.8 in the proper way. Will update you here.

joshm commented on 2019-03-11 13:24

Same issue with libhttp_parser.so.2.8 and then Segmentation fault (core dumped) after downgrading to 2.8.1-2 (and all other 2.8.* versions).

lizonde commented on 2019-02-21 14:34

Problem with electron http-parser 2.8 No such file

Ten0 commented on 2019-02-20 14:12

/usr/lib/electron-postman/electron: error while loading shared libraries: libhttp_parser.so.2.8: cannot open shared object file: No such file or directory

ItachiSan commented on 2019-01-27 14:49

@spectroman & @chipironVacilon, this is because the latest build of Electron 1 is 1 year old; I am trying to rebuild it to see if any changes are required, if not I will make an Electron 1 package for AUR.

If you might, please ask on GH (upstream) to use a newer version of Electron (quite sure I opened a issue already).

chipironVacilon commented on 2019-01-22 10:13

Same error as @spectroman.

spectroman commented on 2019-01-21 12:47

trying to use the package built today I get:

$ postman /usr/lib/electron-postman/electron: error while loading shared libraries: libhttp_parser.so.2.8: cannot open shared object file: No such file or directory

The latest http-parser is 2.9

If I downgrade I get:

$ postman Segmentation fault (core dumped)

ivan_p commented on 2018-10-17 17:55

Version 6.4.4 works for me with this PKGBUILD: https://gist.github.com/ivanpu/66dd3f120ef289a90e8b6fcab9548c8f