Package Details: polyglot-winboard-git 1:r44.5904a29-2

Git Clone URL: https://aur.archlinux.org/polyglot-winboard-git.git (read-only, click to copy)
Package Base: polyglot-winboard-git
Description: UCI/USI/UCCI to XBoard adapter (WinBoard fork)
Upstream URL: http://hgm.nubati.net/cgi-bin/gitweb.cgi?p=polyglot.git;a=summary
Licenses: GPL2
Conflicts: polyglot
Provides: polyglot=r44.5904a29
Replaces: polyglot
Submitter: J5lx
Maintainer: JerryXiao
Last Packager: JerryXiao
Votes: 6
Popularity: 0.000000
First Submitted: 2015-08-19 03:33
Last Updated: 2020-06-24 05:32

Dependencies (2)

Required by (1)

Sources (1)

Latest Comments

Quatro commented on 2020-06-23 09:47

Error building with:

/usr/bin/ld: book_merge.o:(.bss+0x0): multiple definition of `pgheader_magic'; book_make.o:(.bss+0x0): first defined here
/usr/bin/ld: book_merge.o:(.bss+0x8): multiple definition of `pgheader_version'; book_make.o:(.bss+0x8): first defined here
/usr/bin/ld: pgheader.o:(.data.rel.local+0x0): multiple definition of `pgheader_magic'; book_make.o:(.bss+0x0): first defined here
/usr/bin/ld: pgheader.o:(.data.rel.local+0x8): multiple definition of `pgheader_version'; book_make.o:(.bss+0x8): first defined here
collect2: error: ld returned 1 exit status

By commenting it, the declarations on the .h I got it to work.

J5lx commented on 2016-01-16 11:37

Yep, there is (epoch). I'll update the package asap.

corvinusz commented on 2016-01-14 23:37

Hi.
There's some gotcha with package version. Current tgz-snapshot has different git head (d86ce4e...). And this leads to permanent reinstall of package with

```bash
yaourt -Suya
```

May be there is a sense to change version generation?

J5lx commented on 2015-09-12 11:04

Okay, I added that plus conflicts and provides. I didn’t even know there was a polyglot package before (I created this one from scratch), so thanks for the notice. And sorry for the delay, I usually try to react as quickly as possible.

Hazzl commented on 2015-08-27 16:47

Thanks for taking this over. Maybe your package should list that it replaces: the old polyglot package. That would make upgrading easier.