Package Details: polybar-git 3.4.0-2

Git Clone URL: https://aur.archlinux.org/polybar-git.git (read-only)
Package Base: polybar-git
Description: A fast and easy-to-use status bar
Upstream URL: https://github.com/polybar/polybar
Keywords: bar bspwm i3 lemonbar lemonbuddy polybar
Licenses: MIT
Conflicts: polybar
Provides: polybar
Submitter: jaagr
Maintainer: jaagr (NBonaparte, patrick96)
Last Packager: patrick96
Votes: 43
Popularity: 0.494283
First Submitted: 2016-11-19 05:07
Last Updated: 2019-07-30 22:52

Latest Comments

1 2 3 Next › Last »

patrick96 commented on 2019-09-19 13:13

@zack6849 neither, recompiling polybar will fix it. See https://github.com/polybar/polybar/wiki/Known-Issues#error-while-loading-shared-libraries-libjsoncpp

zack6849 commented on 2019-09-19 12:34

Latest revision isn't working, I get the following when trying to run it:

polybar: error while loading shared libraries: libjsoncpp.so.20: cannot open shared object file: No such file or directory

Is this an issue with your package or upstream?

Thanks.

overlysalty commented on 2019-09-18 18:53

I had the same issue as @clpwn due to pyenv. Fixed by running "pyenv global system" before building.

haawda commented on 2019-09-09 21:05

Builds fine without i3-wm installed.

clpwn commented on 2019-01-10 17:47

@patrick96 fixed it.

For the record, my problem was that I had a virtualenv plugin in my shell that was throwing a non-system python binary earlier in my PATH.

Anyone else having this issue: type python3. Make sure your system python is the one you're using when building.

patrick96 commented on 2018-12-30 11:24

@clpwn xcbgen detection works fine for me. Do you use Anaconda for python? If so, there is a known issue with xcbgen detection: https://github.com/jaagr/polybar/wiki/Known-Issues#missing-required-python-module-xcbgen-with-anaconda

Otherwise you may be experiencing the same issue as in https://github.com/jaagr/polybar/issues/1496. The OP has yet to provide us with the results of our troubleshooting instructions. If anaconda is indeed not the problem, we would appreciate it if you could go over to the linked issue and help with troubleshooting.

clpwn commented on 2018-12-30 03:15

Even with reinstalling xcb-proto, I get this error while building. Just me?

-- Searching for xcbgen with python2
-- Searching for xcbgen with python2.7
-- Searching for xcbgen with python3
-- Searching for xcbgen with python
CMake Error at lib/xpp/CMakeLists.txt:70 (message):
  Missing required python module: xcbgen

nathias commented on 2018-08-02 10:33

it was a problem with xcbgen, like in this closed issue https://github.com/jaagr/polybar/issues/502

I resolved it by reinstalling xcb-proto package. Thanks for the help!

patrick96 commented on 2018-08-02 06:11

@nathias That error shouldn't affect the build. What error is actually printed in the terminal, when the build fails?

nathias commented on 2018-08-01 16:53

@patrick96 sorry, I assumed there was a recurring issue. The error is pthread_create exist failed... my error log is here: https://gist.github.com/nath1as/f3a0b68c8168b7537dee5ffc20949fd3