Package Details: polybar-git 3.4.0-4

Git Clone URL: https://aur.archlinux.org/polybar-git.git (read-only, click to copy)
Package Base: polybar-git
Description: A fast and easy-to-use status bar
Upstream URL: https://github.com/polybar/polybar
Keywords: bar bspwm i3 lemonbar lemonbuddy polybar
Licenses: MIT
Conflicts: polybar
Provides: polybar
Submitter: jaagr
Maintainer: jaagr (NBonaparte, patrick96)
Last Packager: patrick96
Votes: 48
Popularity: 0.170992
First Submitted: 2016-11-19 05:07
Last Updated: 2020-06-09 19:49

Dependencies (21)

Required by (5)

Sources (1)

Latest Comments

1 2 3 4 Next › Last »

patrick96 commented on 2020-07-13 21:57

@TrueBers Don't use the mpd module if you don't want polybar to try to connect to mpd. libmpd cannot be an optional dependency, polybar's optional dependencies are only optional at compile-time, at runtime most of them are mandatory if polybar was compiled with that feature.

TrueBers commented on 2020-07-13 13:39

Shouldn't libmpd be an optional dependency as it's stated on Github? It's bashing mpd socket every second which is very annoying.

jameh commented on 2020-05-17 00:55

ah - I realized that polybar -vvv doesn't use the proper release number, but g5cd7295a is indeed the latest commit... EDIT: gotcha - looking forward to 3.5 :D

patrick96 commented on 2020-05-17 00:55

@jameh That's how non-release commits are versioned unfortunately. 3.4.0-106-g5cd7295a is newer than 3.4.3. The master branch where git describe gets the version information doesn't know about patch releases (3.4.X), it only knows about minor releases (3.X.0).

But we want to adapt a different branching scheme in 3.5.0, so that this doesn't happen anymore.

jameh commented on 2020-05-17 00:34

I feel like I might be messing something up, but this only installs 3.4.0-106-g5cd7295a for me which is out-of-date. Looking at the PKGBUILD, git -C polybar describe --long --tags returns 3.4.0-106-g5cd7295a whereas git -C polybar log shows the most recent commits. (We're past 3.4.3 now)

patrick96 commented on 2020-01-31 06:14

@milk Thanks, fixed

milk commented on 2020-01-30 23:28

polybar-git currently fails when make with mkchrootpkg / testing-x86_64-build

-- Configuring done
-- Generating done
-- Build files have been written to: /build/polybar-git/src/polybar/build
Scanning dependencies of target doc_html
[  1%] sphinx-build html: see doc/builder-html.log
WARNING: html_static_path entry '/build/polybar-git/src/polybar/doc/_static' does not exist
[  1%] Built target doc_html
Scanning dependencies of target doc_man
[  2%] sphinx-build man: see doc/builder-man.log
WARNING: html_static_path entry '/build/polybar-git/src/polybar/doc/_static' does not exist
[  2%] Built target doc_man
Scanning dependencies of target doc
[  2%] Built target doc
[  3%] Generating ../../../lib/xpp/include/xpp/proto/x.hpp
Traceback (most recent call last):
  File "/build/polybar-git/src/polybar/lib/xpp/generators/cpp_client.py", line 3193, in <module>
    module.generate()
  File "/usr/lib/python3.8/site-packages/xcbgen/state.py", line 126, in generate
    item.out(name)
  File "/build/polybar-git/src/polybar/lib/xpp/generators/cpp_client.py", line 3007, in cpp_event
    cpp_event = CppEvent(self.opcodes[name], opcode, c_name, _ns, name, self.fields)
  File "/build/polybar-git/src/polybar/lib/xpp/generators/cppevent.py", line 207, in __init__
    for name in self.names[0:-1]:
TypeError: 'map' object is not subscriptable
make[2]: *** [lib/xpp/CMakeFiles/xpp.dir/build.make:74: ../lib/xpp/include/xpp/proto/x.hpp] Error 1
make[2]: *** Deleting file '../lib/xpp/include/xpp/proto/x.hpp'
make[1]: *** [CMakeFiles/Makefile2:521: lib/xpp/CMakeFiles/xpp.dir/all] Error 2
make: *** [Makefile:130: all] Error 2
==> ERROR: A failure occurred in build().

patrick96 commented on 2019-10-05 14:42

@nicocot best ask the pamac people. But generally removing the build directory pamac used for polybar should force pamac to recompile

nicocot commented on 2019-10-05 14:36

@patrick96 I'm using pamac-manager and I don't know how to recompile with this package manager. I removed and reinstalled the polybar-git package several times with pamac-manager, without success.

patrick96 commented on 2019-10-05 14:30

@nicocot Please only use the symlink method as a last resort when you can't recompile. It could potentially break other programs.