Package Details: podman-compose 0.1.5-3

Git Clone URL: https://aur.archlinux.org/podman-compose.git (read-only, click to copy)
Package Base: podman-compose
Description: a script to run docker-compose.yml using podman
Upstream URL: https://github.com/containers/podman-compose
Licenses: GPLv2
Submitter: alevalv
Maintainer: alevalv
Last Packager: alevalv
Votes: 6
Popularity: 1.53
First Submitted: 2019-11-19 21:06
Last Updated: 2020-05-05 03:34

Latest Comments

mahmoudhossam commented on 2020-05-11 08:20

@alevalv python-yaml-5.3.1-1 is up to date. Maybe the PKGBUILD is confusing the system python with the one pyenv uses? I think the PKGBUILD should explicitly use the system python instead of whatever default the user might have.

alevalv commented on 2020-05-07 16:31

@mahmoudhossam you must be missing python-yaml for some unknown reason. The package builds fine on my machine.

mahmoudhossam commented on 2020-05-06 07:13

the package() step fails with the following error:

==> Starting package()...
Traceback (most recent call last):
  File "setup.py", line 9, in <module>
    from podman_compose import __version__ as podman_compose_version
  File "/home/mahmoud/.cache/yay/podman-compose/src/podman-compose-0.1.5/podman_compose.py", line 32, in <module>
    import yaml
ModuleNotFoundError: No module named 'yaml'
==> ERROR: A failure occurred in package().
    Aborting...
Error making: podman-compose

jokke commented on 2020-05-04 17:13

please add:

makedepends=('python-setuptools')

Thank you!

qubidt commented on 2019-11-29 23:10

This should probably have a dependency: podman, no?