Package Details: pocketsphinx 5prealpha-10

Git Clone URL: https://aur.archlinux.org/pocketsphinx.git (read-only, click to copy)
Package Base: pocketsphinx
Description: Lightweight speech recognition engine, specifically tuned for handheld and mobile devices, though it works equally well on the desktop.
Upstream URL: http://cmusphinx.sourceforge.net
Keywords: mobile recognition speech
Licenses: BSD
Submitter: None
Maintainer: Martchus
Last Packager: Martchus
Votes: 73
Popularity: 1.20
First Submitted: 2008-08-08 21:47
Last Updated: 2020-05-12 15:48

Pinned Comments

Martchus commented on 2020-01-19 12:15

All my packages are managed at GitHub where you can also contribute directly: https://github.com/Martchus/PKGBUILDs
There also exist a binary repository: https://wiki.archlinux.org/index.php/Unofficial_user_repositories#ownstuff

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7

marcs commented on 2013-01-02 02:08

Updated to the .8 version and checked with namcap.
I've added the dependency to sphinxbase >= .8 too for consistency, if there's a missing dependence is normal 'cause sphinxbase is still at version .7

chemist69 commented on 2011-03-30 19:11

Hi, I get the following error during the build process:
[...]
cython -o pocketsphinx.c pocketsphinx.pyx -I/usr/include/python2.7 -I/usr/include/python2.7 -I/usr/include/sphinxbase -I/python

Error compiling Cython file:
------------------------------------------------------------
...

cdef set_iter(NGramIter self, ngram_iter_t *itor)

cdef class HuffCode:
cdef huff_code_t *hc
cdef file fh
^
------------------------------------------------------------

sphinxbase.pxd:148:9: 'file' is not a type identifier

make[1]: *** [pocketsphinx.c] Error 1
make[1]: Leaving directory `/home/apl/builds/pocketsphinx/src/pocketsphinx-0.6.1/python'
make: *** [all-recursive] Error 1

chemist69 commented on 2011-03-30 17:55

Hi, I get the following error during the build process:
[...]
cython -o pocketsphinx.c pocketsphinx.pyx -I/usr/include/python2.7 -I/usr/include/python2.7 -I/usr/include/sphinxbase -I/python

Error compiling Cython file:
------------------------------------------------------------
...

cdef set_iter(NGramIter self, ngram_iter_t *itor)

cdef class HuffCode:
cdef huff_code_t *hc
cdef file fh
^
------------------------------------------------------------

sphinxbase.pxd:148:9: 'file' is not a type identifier

make[1]: *** [pocketsphinx.c] Error 1
make[1]: Leaving directory `/home/apl/builds/pocketsphinx/src/pocketsphinx-0.6.1/python'
make: *** [all-recursive] Error 1

td123 commented on 2010-11-26 03:50

I'll update this as soon as sphinxbase is fixed.

gee commented on 2010-11-26 02:26

0.6.1 was released a couple days after last update here.

kalio commented on 2010-06-14 20:43

Thank you, it works now! :)

td123 commented on 2010-06-14 18:34

updated pocketsphinx to 0.6

@linkmaster03
The sphinxbase PKGBUILD is broken.
I fixed it and posted it to the comments section of sphinxbase.
You can wait for the maintainer to update it or make it yourself in the mean time.

kalio commented on 2010-06-14 01:11

I cannot get this package to build. When ./configure is run, it says that it cannot find SphinxBase (even though I have it installed), and it errors out.