Package Details: plymouth-kcm 5.17.0-1

Git Clone URL: https://aur.archlinux.org/plymouth-kcm.git (read-only, click to copy)
Package Base: plymouth-kcm
Description: KCM to manage the Plymouth (Boot) theme
Upstream URL: https://cgit.kde.org/plymouth-kcm.git/
Keywords: kcm kde plasma plymouth
Licenses: GPL
Submitter: faemir
Maintainer: None
Last Packager: jamesjon
Votes: 6
Popularity: 0.135449
First Submitted: 2017-06-02 13:05
Last Updated: 2019-10-20 20:05

Latest Comments

1 2 Next › Last »

jamesjon commented on 2019-10-21 08:27

Yes, that seems to be the problem. Try another virtual machine version, I don't know if I would give you problems with the version you currently have of kde plasma. May be.

Mthw commented on 2019-10-21 08:08

I do have Plasma 5.17 but I also have Qt5.14 which might be the problem. Log(likely the same): https://pastebin.com/fzegpwHa

jamesjon commented on 2019-10-20 20:02

@Mthw

Try now... Do you have version 5.17.0 of kde plasma? This module is only compatible with the latest plasma version.

Mthw commented on 2019-10-20 18:54

Last version isn't buildable for me: https://pastebin.com/qPuipLQM

librewish commented on 2019-07-25 03:14

update pkgbuild to download sources from 5.16.3

doskoi commented on 2018-10-18 15:09

@edarblanco: https://wiki.archlinux.org/index.php/Makepkg#Signature_checking

edarblanco commented on 2018-10-18 12:48

GPG error ==> Verificando las firmas de las fuentes con gpg... plymouth-kcm-5.14.1.tar.xz ... HA FALLADO (clave pública desconocida EC94D18F7F05997E) ==> ERROR: ¡No se ha podido verificar alguna de las firmas PGP!

egrupled commented on 2017-10-29 13:26

Can you add gpg verification to PKGBUILD? It can look like this:

# Maintainer: Daniel Cohen <dan@supercore.co.uk>
pkgname=plymouth-kcm
pkgver=5.11.2
pkgrel=1
pkgdesc="A KCM for configuring Plymouth"
arch=('any')
url="https://cgit.kde.org/plymouth-kcm.git/"
license=('GPL')
depends=('plymouth' 'knewstuff' 'kconfig' 'kconfigwidgets' 'ki18n' 'kdeclarative')
makedepends=('cmake' 'kdoctools' 'extra-cmake-modules')
optdepends=()
options=()
source=("https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('c4c91ed9de389c82bb28dc064caf4791c9a6805f396f4afcca8f681b752d2fb6'
'SKIP')
validpgpkeys=('2D1D5B0588357787DE9EE225EC94D18F7F05997E')

prepare() {
mkdir -p $srcdir/${pkgname}-$pkgver/build
}

build() {
cd "$srcdir/${pkgname}-$pkgver/build"
cmake .. -DCMAKE_INSTALL_PREFIX=`kf5-config --prefix` \
-DCMAKE_BUILD_TYPE=Release \
-DBUILD_TESTING=OFF
make
}

package() {
cd "$srcdir/${pkgname}-$pkgver/build"
make DESTDIR="$pkgdir" install
}

faemir commented on 2017-06-02 17:35

That didn't seem to help on my machine, installing extra-cmake-modules solved that issue. I'll add that to the make deps.

raist356 commented on 2017-06-02 16:19

Add a flag with -DCMAKE_PREFIX_PATH=/usr/share/ECM

==> Starting build()...
CMake Error at CMakeLists.txt:24 (find_package):
Could not find a package configuration file provided by "ECM" (requested
version 0.0.8) with any of the following names:

ECMConfig.cmake
ecm-config.cmake

Add the installation prefix of "ECM" to CMAKE_PREFIX_PATH or set "ECM_DIR"
to a directory containing one of the above files. If "ECM" provides a
separate development package or SDK, be sure it has been installed.


-- Configuring incomplete, errors occurred!