Package Details: plymouth-git 0.9.5.r6.g8176dc5-1

Git Clone URL: https://aur.archlinux.org/plymouth-git.git (read-only, click to copy)
Package Base: plymouth-git
Description: A graphical boot splash screen with kernel mode-setting support (Development version)
Upstream URL: https://www.freedesktop.org/wiki/Software/Plymouth/
Licenses: GPL
Conflicts: plymouth, plymouth-legacy, plymouth-nosystemd
Provides: plymouth
Submitter: PirateJonno
Maintainer: Taijian
Last Packager: Taijian
Votes: 253
Popularity: 1.45
First Submitted: 2009-05-02 09:53
Last Updated: 2020-08-23 12:07

Dependencies (8)

Required by (128)

Sources (16)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Daniel071 commented on 2020-08-16 10:01

@zynex: I had the same error as you had, I re-installed the base-devel package and now the build worked! Thanks!

zynex commented on 2020-07-17 20:48

Tried downloading the package and build it with pkgbuild, got the same error. Might be something I have installed that collide with it. Worked with previous release though.

[EDIT] Found the problem, I had somehow removed some packages from the base-devel group. Saw it them Octopi also failed to compile :)

Taijian commented on 2020-07-16 13:45

@zynex: Sorry to have to say this, but it 'works for me'.

Have your tried building in a clean chroot? Or at least with plain makepkg, i.e. without an AUR-helper?

zynex commented on 2020-07-16 09:42

/tmp/pikaur/build/plymouth-git/src/plymouth/configure: line 11825: syntax error near unexpected token IMAGE,' /tmp/pikaur/build/plymouth-git/src/plymouth/configure: line 11825:PKG_CHECK_MODULES(IMAGE, libpng >= 1.2.16 )' ==> FEL: Ett fel uppstod i build(). Avbryter...

Getting error when trying to compile it. Any idea what it could be. libpng is at version 1.6.37-3.

Taijian commented on 2020-07-01 20:57

@stertingen OK, that should be possible - do you have a proposal for modifying the install hook?

stertingen commented on 2020-07-01 17:28

Right now, the initcpio install hook copies the spinner theme files if the bgrt themes is selected.

I'd like to propose that the install hook should look into the ImageDir option of the plymouth theme file and copy this. This way, I can customize a plymouth theme by copying the bgrt theme without modifying the install hook.

Anonymous comment on 2019-09-08 19:54

The Cantarell fonts (Regular and Thin) need to be added to the plymouth-encrypt install script. The default BGRT theme uses them for the password dialog and update messages. A optional dependency to 'cantarell-fonts' would also make sense.

Depau commented on 2019-06-01 01:09

When selecting the BGRT theme, the Spinner theme should also be selected as it's a variation and images are recycled.

Here you can find my commit with patched mkinitcpio install hooks, if you'd like to merge: https://git.depau.eu/Depau/plymouth-git-bgrt_fix

PedroHLC commented on 2019-03-04 12:44

checking for intltool-extract... no 
configure: error: intltool-extract is required to build plymouth 
==> ERROR: A failure occurred in build(). 
Aborting...

intltool seems to be required for boot. (New dep as it wasn't required yesterday)

Gigadoc2 commented on 2019-02-25 13:55

Could you change the git url to https? The sources are not verified, so adding transport encryption and CA trust might increase security a little bit here.