Package Details: plumed-mpi 2.5.2-1

Git Clone URL: https://aur.archlinux.org/plumed-mpi.git (read-only)
Package Base: plumed-mpi
Description: An open source plugin for free energy calculations in molecular systems which works together with some of the most popular molecular dynamics engines (with MPI support)
Upstream URL: http://www.plumed.org/
Licenses: GPL
Submitter: dviktor
Maintainer: dviktor
Last Packager: dviktor
Votes: 1
Popularity: 0.018034
First Submitted: 2019-01-31 13:39
Last Updated: 2019-08-13 13:39

Dependencies (11)

Required by (2)

Sources (1)

Latest Comments

dviktor commented on 2019-04-16 10:13

@hseara Thank you a lot for your contribution! Fixed now.

hseara commented on 2019-04-16 09:41

Hi dviktor, Why don't you use:

--program-suffix=mpi            append SUFFIX to installed program names

Then both plumed and plumed-mpi can coexist. Then you can remove plumed from "provides". This would be best as the mpi version does not provide the same capabilities as the non-mpi version. For example, you cannot compile non-mpi gromacs against it, that is what most arch users in their desktops will do.

Also please install the software in the canonical paths, i. e. /usr.

--prefix=/usr

This is always recommended in archlinux. The /opt directory is reserved for large self-contained programs, like CUDA, that it is not the case of plumed.

Packaging guidelines