Package Details: plplot 5.15.0-2

Git Clone URL: https://aur.archlinux.org/plplot.git (read-only)
Package Base: plplot
Description: A cross-platform software package for creating scientific plots
Upstream URL: http://plplot.sourceforge.net/
Licenses: custom, LGPL
Submitter: None
Maintainer: migueldvb
Last Packager: migueldvb
Votes: 44
Popularity: 0.211906
First Submitted: 2005-06-08 03:23
Last Updated: 2019-09-16 20:41

Dependencies (12)

Required by (9)

Sources (1)

Latest Comments

1 2 3 Next › Last »

migueldvb commented on 2019-09-16 20:44

Thanks, the PKGBUILD has been updated.

Aelerinya commented on 2019-08-21 16:17

PLplot is affected by the gcc 6 change is the isystem flag, causing an error like this (at least for me) :

/usr/include/c++/9.1.0/cstdlib:75:15: fatal error: stdlib.h: No such file or directory 75 | #include_next <stdlib.h> |

I fixed it by adding this command between the call to cmake and the call to make in the build script : find . -name '*.make' -exec sed -i 's|-isystem /usr/include ||g' '{}' ';' It just removes the '-isystem /usr/include' from every Makefiles generated by CMake, which were causing the issue.

jankoh commented on 2019-01-13 12:31

End of last year gnudatalanguage was updated to use the version of plpot. It needs plplot>5.11 to be compiled with "-DOLD_WXWIDGETS:BOOL=ON" acouring to the README.

Is there any chance to get plplot compiled with that option enabled? Or anyhing known against such a change?

Thanks, Jan

migueldvb commented on 2018-06-18 21:50

Updating to 5.13.0

not_anonymous commented on 2018-05-13 15:06

from namcap run:

plplot E: Dependency lua detected and not included (libraries ['usr/lib/liblua.so.5.3'] needed in files ['usr/lib/lua/5.3/plplot/plplotluac.so']) plplot E: Dependency gcc-ada detected and not included (libraries ['usr/lib/libgnat-8.so'] needed in files ['usr/lib/libplplotada.so.2.1.0']) plplot E: Dependency java-environment detected and not included (found class files usr/share/java/plplot.jar)

anatolyb commented on 2015-09-14 13:41

migueldvb: thank you, I should temporary remove wxgtk2.8, wxpython2.8, and wxgtk2.9 packeages for successful build.

migueldvb commented on 2015-09-11 19:25

anatolyb: It builds fine for me with wxgtk 3.0.2-4 with some wx warnings. I think that you need to upgrade the wxgtk and wxpython packages.

anatolyb commented on 2015-09-11 09:57

build fails at 25%. the issue is probably in wxwidgets:

Scanning dependencies of target plplotwxwidgets
[ 25%] Building CXX object bindings/wxwidgets/CMakeFiles/plplotwxwidgets.dir/wxPLplotstream.cpp.o
In file included from /usr/include/c++/5.2.0/type_traits:35:0,
from /usr/include/wx-2.9/wx/strvararg.h:26,
from /usr/include/wx-2.9/wx/string.h:51,
from /usr/include/wx-2.9/wx/memory.h:16,
from /usr/include/wx-2.9/wx/object.h:20,
from /usr/include/wx-2.9/wx/wx.h:16,
from /tmp/yaourt-tmp-anatoly/aur-plplot/src/plplot-5.11.1/bindings/wxwidgets/wxPLplotstream.cpp:22:
/usr/include/c++/5.2.0/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
#error This file requires compiler and library support for the \
^
In file included from /usr/include/wx-2.9/wx/string.h:51:0,
from /usr/include/wx-2.9/wx/memory.h:16,
from /usr/include/wx-2.9/wx/object.h:20,
from /usr/include/wx-2.9/wx/wx.h:16,
from /tmp/yaourt-tmp-anatoly/aur-plplot/src/plplot-5.11.1/bindings/wxwidgets/wxPLplotstream.cpp:22:
/usr/include/wx-2.9/wx/strvararg.h:346:18: error: ‘is_enum’ in namespace ‘std’ does not name a template type
typedef std::is_enum<T> is_enum;
^
/usr/include/wx-2.9/wx/strvararg.h:350:54: error: ‘is_enum’ was not declared in this scope
enum { value = wxFormatStringSpecifierNonPodType<is_enum::value>::value };
^
/usr/include/wx-2.9/wx/strvararg.h:350:68: error: template argument 1 is invalid
enum { value = wxFormatStringSpecifierNonPodType<is_enum::value>::value };

Styx85 commented on 2015-05-29 08:18

there is a patch creating compatibility to plplot 5.11 for gnudatalanguage

https://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-lang/gdl/files/0.9.5-plplot.patch?logsort=rev&view=log&sortby=log&pathrev=HEAD

James-T commented on 2015-04-18 15:12

Please note:
At present gnudatalanguage will not build with 5.11.0, so I am delaying the update until gnudatalanguage upstream fix the build.