Package Details: platformio 5.1.1-1

Git Clone URL: https://aur.archlinux.org/platformio.git (read-only, click to copy)
Package Base: platformio
Description: A cross-platform code builder and library manager
Upstream URL: https://github.com/platformio/platformio-core/
Keywords: arduino builder platformio
Licenses: Apache
Conflicts: platformio-git
Submitter: zer0chain
Maintainer: zer0chain (Jake)
Last Packager: Jake
Votes: 62
Popularity: 1.21
First Submitted: 2016-02-11 15:01
Last Updated: 2021-03-17 20:07

Latest Comments

« First ‹ Previous 1 2 3 4 5

zer0chain commented on 2016-06-20 09:21

@buckket I agree it is a bad idea. I thought platformio will moved to the next version of click and so it shoud be temporary to use this patch on setup.py. However, I think it is also a bad idea to use an out-of-date package in AUR when the last version if available in the official repository.

buckket commented on 2016-06-17 23:36

Dear maintainer,

patching setup.py to allow the usage of click v6 is a bad idea, there is a reason this restriction is in place: click v6 introduces a bug to platformio. [0]

Instead I suggest adjusting the PKGBUILD dependency to explicitly list an older, but compatible, version of click.
Someone already has created a python-click-5.1 package [1], which would be a perfect fit.

[0]: https://github.com/pallets/click/issues/473
[1]: https://aur.archlinux.org/packages/python-click-5.1/

zer0chain commented on 2016-04-13 20:56

avrdude is a known issue for platformio on Arch, but I do not think that adding these deps is the proper way of solving it.
Best is to use the avrdude provided by Arch rather than the one of platformio. A symbolic link (~/.platformio/packages/tool-avrdude -> /usr/bin/avrdude) do the job for now.

Xeranor commented on 2016-04-13 09:56

Please add
https://aur.archlinux.org/packages/ncurses5-compat-libs/
and
https://aur.archlinux.org/packages/libtinfo-5/
to the dependencies since they are needed to run the version of avrdude.