Package Details: plasma5-applets-mycroft-git r136.9a784bd-1

Git Clone URL: https://aur.archlinux.org/plasma5-applets-mycroft-git.git (read-only, click to copy)
Package Base: plasma5-applets-mycroft-git
Description: Mycroft Ai Plasmoid / Widget for KDE Plasma 5 Desktop
Upstream URL: https://invent.kde.org/utilities/mycroft-plasmoid
Licenses: GPL3
Conflicts: plasma5-applets-mycroft
Provides: plasma5-applets-mycroft
Submitter: z3ntu
Maintainer: z3ntu
Last Packager: z3ntu
Votes: 13
Popularity: 0.104447
First Submitted: 2017-01-19 15:24
Last Updated: 2020-07-11 16:05

Latest Comments

« First ‹ Previous 1 2

notuxius commented on 2018-03-27 14:14

There is Connection error upon trying to enable Mycroft from the applet - i don't have a physical Mycroft device - is it needed?

GLaDTheresCake commented on 2018-02-27 17:51

Package is not installing correctly for some reason:

-- Installing: /home/jari/plasma5-applets-mycroft-git/pkg/plasma5-applets-mycroft-git/usr/share/icons/hicolor/32x32/apps/mycroft-plasma-appicon.svg patching file /home/jari/plasma5-applets-mycroft-git/pkg/plasma5-applets-mycroft-git/usr/share/plasma/plasmoids/org.kde.plasma.mycroftplasmoid/contents/code/pkgstartservice.sh

Hunk #1 FAILED at 1.

1 out of 1 hunk FAILED -- saving rejects to file /home/jari/plasma5-applets-mycroft-git/pkg/plasma5-applets-mycroft-git/usr/share/plasma/plasmoids/org.kde.plasma.mycroftplasmoid/contents/code/pkgstartservice.sh.rej

==> ERROR: A failure occurred in package().

Aborting...

Looking at the rejects file tells me this:

[jari@GLaDOS plasma5-applets-mycroft-git]$ cat /home/jari/plasma5-applets-mycroft-git/pkg/plasma5-applets-mycroft-git/usr/share/plasma/plasmoids/org.kde.plasma.mycroftplasmoid/contents/code/pkgstartservice.sh.rej

--- pkgstartservice.sh.old 2017-03-28 14:42:59.088314085 +0200

+++ pkgstartservice.sh 2017-03-28 14:49:03.106374563 +0200

@@ -1,6 +1,6 @@

#!/bin/bash

-service mycroft-messagebus start

-service mycroft-skills start

-service mycroft-speech-client start

+systemctl --user start mycroft-service.service

+systemctl --user start mycroft-skills.service

+systemctl --user start mycroft-voice.service

paplay /usr/share/sounds/freedesktop/stereo/dialog-error.oga

stardiviner commented on 2017-05-26 09:45

If I use Mycroft Docker image, then which installation path should I select for this Mycroft plasmoid?

z3ntu commented on 2017-03-28 13:15

@stardiviner: Updated the package. Please test!

stardiviner commented on 2017-03-28 08:03

Arch Linux now use systemd now. So the `/usr/share/plasma/plasmoids/org.kde.plasma.mycroftplasmoid/contents/code/*.sh` scripts should change from `service` to `systemctrl`.

z3ntu commented on 2017-03-18 15:26

@OdinEidolon: This applet uses mycroft installed in your home directory (see the post_install script: https://aur.archlinux.org/cgit/aur.git/tree/plasma5-applets-mycroft-git.install?h=plasma5-applets-mycroft-git). I tried once to make this applet compatible with the mycroft package but I failed because of permission problems. If you manage to get it working, I will gladly accept these changes into the package.

OdinEidolon commented on 2017-03-18 09:31

How can this Not depend on mycroft-core?