Package Details: pkcrack 1.2.2-4

Git Clone URL: https://aur.archlinux.org/pkcrack.git (read-only, click to copy)
Package Base: pkcrack
Description: An algorithm for breaking the PkZip cipher that was devised by Eli Biham and Paul Kocher.
Upstream URL: https://www.unix-ag.uni-kl.de/~conrad/krypto/pkcrack.html
Keywords: archive cryptography pkzip
Licenses: custom
Conflicts: libextractor
Submitter: marcs
Maintainer: marcs
Last Packager: marcs
Votes: 1
Popularity: 0.000000
First Submitted: 2016-08-11 15:17
Last Updated: 2021-03-08 14:34

Latest Comments

jfly commented on 2021-11-30 04:18

This is failing to install for me when trying to download the .tar.gz file. It looks like curl isn't trusting the HTTPS cert for reasons I don't fully understand (chromium does trust it):

curl -vvv https://www.unix-ag.uni-kl.de/
*   Trying 131.246.124.83:443...
* Connected to www.unix-ag.uni-kl.de (131.246.124.83) port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
*  CAfile: /etc/ssl/certs/ca-certificates.crt
*  CApath: none
* TLSv1.3 (OUT), TLS handshake, Client hello (1):
* TLSv1.3 (IN), TLS handshake, Server hello (2):
* TLSv1.3 (IN), TLS handshake, Encrypted Extensions (8):
* TLSv1.3 (IN), TLS handshake, Certificate (11):
* TLSv1.3 (OUT), TLS alert, unknown CA (560):
* SSL certificate problem: unable to get local issuer certificate
* Closing connection 0
curl: (60) SSL certificate problem: unable to get local issuer certificate
More details here: https://curl.se/docs/sslcerts.html

curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.

Some Googling leads to believe that this is a misconfiguration on www.unix-ag.uni-kl.de related to an incomplete certificate chain. Note the "B" level score on ssllabs.com: https://www.ssllabs.com/ssltest/analyze.html?d=www.unix%2dag.uni%2dkl.de&s=131.246.124.83

I worked around this by adding this (dangerous!) line to the top of the PKGBUILD file:

DLAGENTS=("https::/usr/bin/curl -k -o %o %u")

dreieck commented on 2018-11-28 20:34

Conflicts with package libextractor:
Both provide the file /usr/bin/extract.

Please update conflicts entry.

marcs commented on 2016-09-06 13:45

Fixed, the packaging function was messed up! :P

You were doing nothing wrong.

avarx commented on 2016-08-29 17:35

1.2.2-1's not working for me (yaourt). I can build it but I'm not able to run it.
What am I doing wrong?