Package Details: piskel 0.15.0-5

Git Clone URL: https://aur.archlinux.org/piskel.git (read-only, click to copy)
Package Base: piskel
Description: A free online editor for animated sprites & pixel art.
Upstream URL: https://github.com/piskelapp/piskel
Keywords: animation art editor graphics pixel
Licenses: Apache
Submitter: turtlewit
Maintainer: ongyx
Last Packager: ongyx
Votes: 0
Popularity: 0.000000
First Submitted: 2018-04-06 20:52
Last Updated: 2021-06-13 11:34

Latest Comments

1 2 3 Next › Last »

ongyx commented on 2021-06-14 05:58

@makeworld it doesn't seem so:

$ phantomjs
bash: phantomjs: command not found
$ piskel
...

Piskel runs fine without PhantomJS.

makeworld commented on 2021-06-13 18:38

phantomjs might be a runtime dependency. I'm not sure.

ongyx commented on 2021-06-13 11:30

Ok, I'll add phantomjs as a make dependency. Thanks for telling me about it!

makeworld commented on 2021-06-12 20:26

Thanks for the updates, but I still can't install this. I think the key line is npm ERR! PhantomJS not found on PATH. I installed phantomjs-bin and then the piskel install worked. This is the error log from when PhantomJS wasn't installed:

==> Starting build()...
npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE   package: 'karma@1.7.0',
npm WARN EBADENGINE   required: { node: '0.10 || 0.12 || 4 || 5 || 6 || 7' },
npm WARN EBADENGINE   current: { node: 'v16.3.0', npm: '7.17.0' }
npm WARN EBADENGINE }
npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE   package: 'http2@3.3.7',
npm WARN EBADENGINE   required: { node: '>=0.12.0 <9.0.0' },
npm WARN EBADENGINE   current: { node: 'v16.3.0', npm: '7.17.0' }
npm WARN EBADENGINE }
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated cryptiles@2.0.5: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
npm WARN deprecated json3@3.3.2: Please use the native JSON object instead of JSON 3
npm WARN deprecated chokidar@1.7.0: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
npm WARN deprecated xmldom@0.1.31: Deprecated due to CVE-2021-21366 resolved in 0.5.0
npm WARN deprecated jscs-preset-wikimedia@1.0.1: No longer maintained. We recomment migrating to ESLint with eslint-config-wikimedia.
npm WARN deprecated boom@2.10.1: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated sntp@1.0.9: This module moved to @hapi/sntp. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
npm WARN deprecated nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info.
npm WARN deprecated phantomjs@2.1.7: Package renamed to phantomjs-prebuilt. Please update 'phantomjs' package references to 'phantomjs-prebuilt'
npm WARN deprecated uuid@2.0.3: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
npm WARN deprecated phantomjs-prebuilt@2.1.16: this package is now deprecated
npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
npm WARN deprecated tough-cookie@2.2.2: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130
npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm WARN deprecated mkdirp@0.5.0: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)
npm WARN deprecated har-validator@2.0.6: this library is no longer supported
npm WARN deprecated hoek@2.16.3: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated http2@3.3.7: Use the built-in module in node 9.0.0 or newer, instead
npm WARN deprecated request@2.67.0: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated request@2.75.0: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated coffee-script@1.12.7: CoffeeScript on NPM has moved to "coffeescript" (no hyphen)
npm WARN deprecated hawk@3.1.3: This module moved to @hapi/hawk. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
npm WARN deprecated core-js@1.2.7: core-js@<3.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js.
npm WARN deprecated core-js@2.6.12: core-js@<3.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js.
npm ERR! code 1
npm ERR! path /home/makeworld/.cache/yay/piskel/src/piskel-0.15.0/node_modules/phantomjs
npm ERR! command failed
npm ERR! command sh -c node install.js
npm ERR! PhantomJS not found on PATH
npm ERR! Phantom installation failed TypeError [ERR_INVALID_ARG_TYPE]: The "path" argument must be of type string. Received undefined
npm ERR!     at new NodeError (node:internal/errors:363:5)
npm ERR!     at validateString (node:internal/validators:119:11)
npm ERR!     at Object.join (node:path:1172:7)
npm ERR!     at findSuitableTempDirectory (/home/makeworld/.cache/yay/piskel/src/piskel-0.15.0/node_modules/phantomjs/install.js:127:30)
npm ERR!     at /home/makeworld/.cache/yay/piskel/src/piskel-0.15.0/node_modules/phantomjs/install.js:476:19
npm ERR!     at nextTickCallback (/home/makeworld/.cache/yay/piskel/src/piskel-0.15.0/node_modules/kew/kew.js:47:28)
npm ERR!     at processTicksAndRejections (node:internal/process/task_queues:78:11) {
npm ERR!   code: 'ERR_INVALID_ARG_TYPE'
npm ERR! } TypeError [ERR_INVALID_ARG_TYPE]: The "path" argument must be of type string. Received undefined
npm ERR!     at new NodeError (node:internal/errors:363:5)
npm ERR!     at validateString (node:internal/validators:119:11)
npm ERR!     at Object.join (node:path:1172:7)
npm ERR!     at findSuitableTempDirectory (/home/makeworld/.cache/yay/piskel/src/piskel-0.15.0/node_modules/phantomjs/install.js:127:30)
npm ERR!     at /home/makeworld/.cache/yay/piskel/src/piskel-0.15.0/node_modules/phantomjs/install.js:476:19
npm ERR!     at nextTickCallback (/home/makeworld/.cache/yay/piskel/src/piskel-0.15.0/node_modules/kew/kew.js:47:28)
npm ERR!     at processTicksAndRejections (node:internal/process/task_queues:78:11)

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/makeworld/.npm/_logs/2021-06-12T20_25_17_326Z-debug.log
==> ERROR: A failure occurred in build().
    Aborting...
error making: piskel

ongyx commented on 2021-06-12 04:40

@turtlewit I've opened a new PR to upstream, but we probably still need to keep the PKGBUILD patches until 0.16.0 (and the PR is merged).

turtlewit commented on 2021-06-12 03:51

@ongyx Great work! The repo hasn't been updated in over a year, but you might think about opening a pull request to fix this upstream as well.

ongyx commented on 2021-06-12 03:46

@turtlewit @makeworld I managed to build piskel by patching both the grunt dependency issue and the node module temp in the PKGBUILD. Older versions of temp use os.tempDir instead of os.tempdir, which was deprecated from node 7.0.0 onwards:

>> TypeError: os.tmpDir is not a function

This error propagates into Grunt, which causes the tasks to not be registered properly:

Warning: Task "nwjs:windows" not found.

turtlewit commented on 2021-05-06 03:48

@makeworld This seems to be an upstream issue. The git repo hasn't been updated in over a year, and it fails to build with the same error in master. Please open an issue on github. In the meantime, I will disown this package in case anyone else with more knowledge of npm/grunt wants to try and patch it (just fixing the dependency conflict didn't seem to work).

makeworld commented on 2021-05-05 21:43

Fails to install:

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: piskel@0.15.0
npm ERR! Found: grunt@0.4.5
npm ERR! node_modules/grunt
npm ERR!   dev grunt@"0.4.5" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer grunt@"^1.0.1" from grunt-nw-builder@3.1.0
npm ERR! node_modules/grunt-nw-builder
npm ERR!   dev grunt-nw-builder@"3.1.0" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR! 
npm ERR! See /home/makeworld/.npm/eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/makeworld/.npm/_logs/2021-05-05T21_42_34_058Z-debug.log

turtlewit commented on 2020-09-08 02:22

@wlritchi You're right, it's been added, thanks for the heads up.