Package Details: pipewire-v4l2-git 0.3.39.57.g9facfca45-1

Git Clone URL: https://aur.archlinux.org/pipewire-git.git (read-only, click to copy)
Package Base: pipewire-git
Description: Low-latency audio/video router and processor (GIT version) - V4L2 interceptor (GIT version)
Upstream URL: https://pipewire.org
Licenses: MIT
Conflicts: pipewire-v4l2
Provides: pipewire-v4l2=0.3.39.57.g9facfca45
Submitter: sl1pkn07
Maintainer: sl1pkn07
Last Packager: sl1pkn07
Votes: 11
Popularity: 0.71
First Submitted: 2017-09-19 15:57
Last Updated: 2021-10-30 23:30

Dependencies (26)

Required by (1)

Sources (1)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

sl1pkn07 commented on 2021-11-01 13:47

uodate your libcamera package

carlosnewmusic commented on 2021-11-01 13:46

build error https://pastebin.com/3uy4Ui8t

nyanpasu64 commented on 2021-10-30 23:35

It works now. Thanks!

EDIT: I have to run --nocheck because the unit tests fail right now, but that's being tracked at https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/1710#note_1124223 (which hopefully will be fixed soon).

sl1pkn07 commented on 2021-10-30 23:30

ops. true. done

nyanpasu64 commented on 2021-10-30 23:29

Doesn't work. You fixed every provides except for package_pipewire-git()'s...

sl1pkn07 commented on 2021-10-30 23:16

try now

nyanpasu64 commented on 2021-10-30 21:26

I can't install this package anymore:

:: removing pipewire breaks dependency 'pipewire>=0.3.39' required by pipewire-media-session

:: removing pipewire breaks dependency 'pipewire>=0.3.39' required by pipewire-media-session-git

I managed to fix it by switching package_pipewire-git() to provides=("pipewire=${pkgver}", as mentioned in the wiki. Is this an appropriate fix to add here?

AlexTsi commented on 2021-10-22 10:42

This does no longer build. media-session is no longer part of the upstream pipewire repo, it has been moved to its own project, see https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/1bced6b2ef300acce23c0daaeb8f4fc14095f330.

We probably need to remove the pipewire-media-session-git from the provides of this PKGBUILD, and add the media-session-git package as dependency.

xdavidwu commented on 2021-10-01 06:45

../pipewire/meson.build:453:4: ERROR: Program 'rst2man.py' not found

looks like it need python-docutils in makedepends

sl1pkn07 commented on 2021-09-02 16:49

@carlosnewmusic you log is trimmed. please up full log

greetings