Package Details: pipewire-ffmpeg-git 0.3.30.82.gb6559289f-1

Git Clone URL: https://aur.archlinux.org/pipewire-git.git (read-only, click to copy)
Package Base: pipewire-git
Description: Low-latency audio/video router and processor (GIT version) - FFmpeg SPA plugin (GIT version)
Upstream URL: https://pipewire.org
Licenses: MIT
Conflicts: pipewire-ffmpeg
Provides: pipewire-ffmpeg
Submitter: sl1pkn07
Maintainer: sl1pkn07
Last Packager: sl1pkn07
Votes: 9
Popularity: 0.97
First Submitted: 2017-09-19 15:57
Last Updated: 2021-06-14 15:05

Dependencies (27)

Required by (1)

Sources (1)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

sl1pkn07 commented on 2021-06-15 14:33

seems AUR problem. try directly with makepkg

sl1pkn07 commented on 2021-06-15 14:28

why the first warning? webrtc-audio-processing is in makedepends()

carlosnewmusic commented on 2021-06-15 14:22

Warning: Ignoring the webrtc-audio-processing-0.3.1-3 package. Warning: failed to resolve "libwebrtc_audio_processing.so", a dependency of "pipewire-git". Failed to prepare transaction: could not satisfy dependencies: - unable to satisfy dependency "libwebrtc_audio_processing.so" required by pipewire-git

tinywrkb commented on 2021-06-03 11:16

New dependency (untested) webrtc-audio-processing for using the webrtc based echo canceling in the echo canceling module.
I'm not building this package anymore so this is untested but it possible to confirm it's linking against the library by looking in the build log, with ldd, or forcing this feature with -Decho-cancel-webrtc=enabled.

JDAturbo commented on 2021-05-18 18:53

@sl1pkn07 Yes, thank you.

sl1pkn07 commented on 2021-05-18 16:04

@JDAturbo done(?)

JDAturbo commented on 2021-05-18 15:24

Needs an update due to this commit moving the config files:

mv: cannot stat 'etc/pipewire/media-session.d/*.conf': No such file or directory

kleinph commented on 2021-04-12 17:41

@Strykar as also noted in the comment before: use pipewire-common-git packages. They are properly maintained.

Strykar commented on 2021-04-12 17:26

Tried upgrading after a month, I get:

(398/398) checking keys in keyring                                                                                                                        [###############################################################################################] 100%
(398/398) checking package integrity                                                                                                                      [###############################################################################################] 100%
(398/398) loading package files                                                                                                                           [###############################################################################################] 100%
(398/398) checking for file conflicts                                                                                                                     [###############################################################################################] 100%
error: failed to commit transaction (conflicting files)
pipewire-media-session: /etc/pipewire/media-session.d/alsa-monitor.conf exists in filesystem (owned by pipewire-git)
pipewire-media-session: /etc/pipewire/media-session.d/bluez-monitor.conf exists in filesystem (owned by pipewire-git)
pipewire-media-session: /etc/pipewire/media-session.d/media-session.conf exists in filesystem (owned by pipewire-git)
pipewire-media-session: /etc/pipewire/media-session.d/v4l2-monitor.conf exists in filesystem (owned by pipewire-git)
pipewire-media-session: /usr/bin/pipewire-media-session exists in filesystem (owned by pipewire-git)
Errors occurred, no packages were upgraded.

I'd appreciate any pointers..

kleinph commented on 2021-03-23 09:27

@A.J @tallero this AUR package seems to be poorly maintained. Use pipewire-common-git instead.