Package Details: pipewire-common-v4l2-git 0.3.40.r16.gc03d1029-1

Git Clone URL: https://aur.archlinux.org/pipewire-common-git.git (read-only, click to copy)
Package Base: pipewire-common-git
Description: Low-latency audio/video router and processor - V4L2 interceptor
Upstream URL: https://pipewire.org
Licenses: MIT
Conflicts: pipewire-v4l2
Provides: pipewire-v4l2
Submitter: eh5
Maintainer: eh5
Last Packager: eh5
Votes: 4
Popularity: 0.006489
First Submitted: 2021-01-10 08:40
Last Updated: 2021-11-13 20:22

Required by (0)

Sources (1)

Pinned Comments

PedroHLC commented on 2021-01-11 22:53

If someone needs any of these packages pre-built, chaotic-aur builds them hourly...

Latest Comments

1 2 3 4 Next › Last »

eh5 commented on 2021-10-22 02:59

Since pipewire 0.3.39, pipewire-media-session has moved into a separate package base. Hence I have changed some packages in this package base to depends on pipewire-session-manager instead, which also depends on pipewire >= 0.3.39 if it resolves to pipewire-media-session. So it's a little bit tricky to upgrade to 0.3.39 because of circular dependency between this package base with pipewire-media-session.

And here is my guide if you want to build/use pipewire-media-session-git:

  1. Build all packages in package base pipewire-common-git/pipewire-full-git.
  2. Install pipewire-common-git/pipewire-full-git or testing/pipewire which provides pipewire>=0.3.39 with pacman -Udd or pacman -Sdd
  3. Build and install pipewire-media-session-git (depends on pipewire>=0.3.39)
  4. Install the rest of packages you wanted built in step 1.

Once wireplumber has added a provide to pipewire-session-manager, you could then use it instead.

edit: use pipewire-media-session-git instead of media-session-git, which is about to merge into the former.

eh5 commented on 2021-10-18 22:19

@Netboy3

please reconsider adding media-session-git as "depends".

Oh, yes. I was trying to say to not build media-session source in this package base. Sorry for the confusion.

Netboy3 commented on 2021-10-18 13:13

@eh5, please reconsider adding media-session-git as "depends". there are many folks out there using wireplumber instead of media-session. Upstream has intentionally created a balanced hierarchy of pipewire with two sub-projects dealing with media-session management. Creating a dependency on one of the session managers deviates from the intention of the upstream and should really be left to the user to decide.

eh5 commented on 2021-10-18 12:03

Upstream has now separated[1] its example media session pipewire-media-session into a standalone project https://gitlab.freedesktop.org/pipewire/media-session. So I have created a AUR package for it, https://aur.archlinux.org/packages/media-session-git. I would probably change this package to depends on media-session-git when things are settled in upstream.

Currently the media-session is still built as a meson subproject of pipewire here, so you don't have to build&install media-session-git yet.

[1] https://gitlab.freedesktop.org/pipewire/pipewire/-/merge_requests/1024

Edu4rdSHL commented on 2021-07-30 06:02

@eh5, I just saw, nice and thank you!

eh5 commented on 2021-07-30 05:58

@Edu4rdSHL I have done something similar.

Edu4rdSHL commented on 2021-07-29 21:57

Hello, please can you merge this PKGBUILD.patch: https://paste.rs/mmr

libopenaptx was removed from repos and pipewire now depends on libfreeaptx, see https://github.com/archlinux/svntogit-packages/commit/729407a399f990659ffb6472d39989beefb9eddc#diff-3e341d2d9c67be01819b25b25d5e53ea3cdf3a38d28846cda85a195eb9b7203a for more context.

Thank you.

jintseng commented on 2021-06-08 11:53

@eh5 experiencing that error as well (unable to resolve the libwebrtc dep) - I was able to install pipewire by updating my webrtc-audio-processing to version 0.3.1-3 which yay/pacman wasn't updating.

Use yay --getpkgbuild webrtc-audio-processing and build it yourself makepkg then install.

eh5 commented on 2021-06-06 18:43

@Dude803 I guess you would need to update your packages repo, the libwebrtc_audio_processing.so=1-64 is provided by webrtc-audio-processing.

But somehow AUR web also can not recognize libwebrtc_audio_processing.so...

Dude803 commented on 2021-06-06 18:35

Starting yesterday (June 5) I am experiencing a weird error on package upgrade: cannot resolve "libwebrtc_audio_processing.so=1-64", a dependency of "pipewire-common-git". Is this something wrong on my end or is this something wrong with the package?