Package Details: pipe-viewer-git 0.1.2.r0.ge648353-1

Git Clone URL: https://aur.archlinux.org/pipe-viewer-git.git (read-only, click to copy)
Package Base: pipe-viewer-git
Description: A lightweight YouTube client for Linux (CLI/GTK) (fork of straw-viewer)
Upstream URL: https://github.com/trizen/pipe-viewer
Keywords: gtk perl youtube
Licenses: Artistic2.0
Submitter: trizen
Maintainer: trizen
Last Packager: trizen
Votes: 7
Popularity: 0.63
First Submitted: 2020-10-30 16:44
Last Updated: 2021-06-19 14:16

Latest Comments

trizen commented on 2021-06-01 22:33

@m040601: Mozilla::CA is a dependency of LWP::Protocol::https: https://metacpan.org/source/OALDERS/LWP-Protocol-https-6.10/lib/LWP/Protocol/https.pm#L28

But perl-lwp-protocol-https has been patched to work without it: https://github.com/archlinux/svntogit-packages/commit/c1602c30c941135977e5b154fb2c2521067c758e#diff-3e341d2d9c67be01819b25b25d5e53ea3cdf3a38d28846cda85a195eb9b7203a

Therefore, there is no need to install perl-mozilla-ca on ArchLinux.

m040601 commented on 2021-06-01 21:54

A bit confused about the "recommended" or "optional" dependecies.

Version 0.10 installs without problems but, I see this:

==> Starting build()...
WARNING: the following files are missing in your kit:
        META.json
        META.yml
Please inform the author.

Checking prerequisites...
  recommends:
    *  Mozilla::CA is not installed

ERRORS/WARNINGS FOUND IN PREREQUISITES.  You may wish to install the versions
of the modules indicated above before proceeding with this installation

Run 'Build installdeps' to install missing prerequisites.

Created MYMETA.yml and MYMETA.json
Creating new 'Build' script for 'WWW-PipeViewer' version 'v0.1.0'

But I don't see any mention of that "Mozilla CA" in the PKGBUILD description:

yay -S --info pipe-viewer-git

Optional Deps   : ffmpeg  gnome-icon-theme  perl-json-xs  perl-lwp-useragent-cached
                  perl-term-readline-gnu  mpv  vlc  wget  youtube-dl

So is this really "recommended" or not ?

$ pacman -Ss perl mozilla ca

extra/perl-mozilla-ca 20200520-4
    Mozilla's CA cert bundle in PEM format

I dont' want to install extra stuff, if I dont really need it.

m040601 commented on 2021-02-11 22:51

----ADDITONAL COMMENT on Jun 2021

some might think asking to remove gtk3 as a "mandatory" dependency might be exagerated.

After all gtk3 is still needed by so many things, like firefox, thunderbird etc. So everyone must have it on their desktop anyway right ?

No. I dont have them on my Arch Linux Raspberry Pi's. I dont need a "desktop" there. I dont have Xorg there.

Nope, pipe-viewer as a cli app makes it an excelent and snappy text browsing tool for youtube audio.

And I can still watch videos with mpv (framebuffer) without gtk or Xorg, with the same pipe-viewer.

----ORIGINAL COMMENT

Why the gtk mandatory dependency ? Why not make it an optional dependency ? Or an alternative PKGBUILD  "pipe-viewer-no-gtk-git" ?an

Hi trizen, thanks for all your nice work on pipe, straw and youtube viewers. Very interesting tools and very happy user.

Why the gtk mandatory dependency ? Why not make it optional ? So many other perl and python apps with both a cli and an (optional) gtk gui interface do it like that.

I run it perfectly fine with the text interface, and I dont want to install things that I dont need. Because of this dependency beeing mandatory instead of optional I end up with gtk3 in my system.

:: removing gtk3 breaks dependency 'gtk3' required by perl-gtk3

:: removing perl-gtk3 breaks dependency 'perl-gtk3' required by pipe-viewer-git

I suppose the target users of these tools are some what knowledge able users who are at least familiar with the command line. And for sure they are capable of installing the extra that they might feel that they are missing if they think so.

Thanks in advance