Package Details: pioneers 15.6-1

Git Clone URL: https://aur.archlinux.org/pioneers.git (read-only, click to copy)
Package Base: pioneers
Description: A clone of the famous Siedler of Catan game
Upstream URL: http://pio.sourceforge.net/
Licenses: GPL2
Submitter: None
Maintainer: bug
Last Packager: bug
Votes: 78
Popularity: 0.70
First Submitted: 2005-11-11 15:21
Last Updated: 2020-08-04 15:18

Latest Comments

1 2 Next › Last »

lima-lima commented on 2020-07-26 08:59

Regarding niezniszczalny's error, I encountered it as well. I believe it will be fixed upstream in the next release. In the meantime, updating the MAKEPKG file to the following should resolve the issue (it applies a simple patch to the troublesome file before building - see the added prepare() function):

# Maintainer: bug <bug2000@gmail.com>
# Contributor: Lone_Wolf <lonewolf@xs4all.nl>
pkgname=pioneers
pkgver=15.5
pkgrel=1
pkgdesc="A clone of the famous Siedler of Catan game"
arch=('i686' 'x86_64')
url="http://pio.sourceforge.net/"
license=('GPL2')
depends=('gtk2')
makedepends=('pkgconfig' 'intltool' 'librsvg' 'itstool')
source=(http://downloads.sourceforge.net/pio/$pkgname-$pkgver.tar.gz)
md5sums=('0fdf4e819dfdf5bf2df1a110fbfb440a')
prepare() {
    cd "$srcdir/$pkgname-$pkgver/common"
    patch game.h <<EOF
140c140
< const gchar *default_player_style;
---
> extern const gchar *default_player_style;
EOF
}
build() {
  cd "$srcdir/$pkgname-$pkgver"
  ./configure --prefix=/usr
  make || return 1
}
package() {
  cd "$srcdir/$pkgname-$pkgver"
  make DESTDIR="$pkgdir" install
}

bug commented on 2020-07-24 10:48

Please report the issue to upstream. In the mean while, you can try to compile with an older GCC.

niezniszczalny commented on 2020-07-19 16:13

Error:

https://pastebin.com/cZvtMxAp

flu commented on 2017-04-22 11:53

Better PKGBUILD :)

https://pastebin.com/ptMuMBsj

Raimar commented on 2016-06-15 20:37

namcap says:
pioneers E: Dependency gtk3 detected and not included (libraries ['usr/lib/libgdk-3.so.0', 'usr/lib/libgtk-3.so.0'] needed in files ['usr/bin/pioneers', 'usr/bin/pioneers-editor', 'usr/bin/pioneers-server-gtk'])
pioneers E: Dependency libnotify detected and not included (libraries ['usr/lib/libnotify.so.4'] needed in files ['usr/bin/pioneers'])
pioneers W: Dependency included and not needed ('gtk2')

thylakoid commented on 2015-09-25 00:38

I accidentally flagged this. I don't know how to undo it.

pnobel commented on 2014-07-29 22:47

The PKGBUILD should say

sha256sum='6ddac3808eaec78afc96801a86f64e6e599d9f4ff30ad00960a38ada5e643eca'

Also the "make DESTDIR="$pkgdir" install" should be in a package() function.

pnobel commented on 2014-07-29 19:40

The current version is 15.2.

barchiesi commented on 2013-03-27 22:32

I fixed my issues by installing extra/librsvg. Perhaps you could add that to the depends?

bug commented on 2013-03-25 08:00

Not sure. I never really encountered the issue. As you say, you can't even reproduce it on a different machine.
If you figure anything, please let me know.