Package Details: piglit-git r11303.d4d9353b7-1

Git Clone URL: https://aur.archlinux.org/piglit-git.git (read-only, click to copy)
Package Base: piglit-git
Description: OpenGL implementation testing suite. Provides a simple means to perform regression tests.
Upstream URL: http://piglit.freedesktop.org/
Licenses: GPL2, GPL3, LGPL2.1
Conflicts: piglit
Provides: piglit
Submitter: Omar007
Maintainer: Omar007
Last Packager: Omar007
Votes: 1
Popularity: 0.000000
First Submitted: 2016-05-21 17:01
Last Updated: 2021-02-14 19:33

Dependencies (17)

Required by (0)

Sources (1)

Latest Comments

Lone_Wolf commented on 2021-02-14 20:49

The error was indeed in waffle package, not in piglit-git .

I've uploaded an adjusted waffle pacakge.

Omar007 commented on 2021-02-14 19:32

@Lone_Wolf: I have added support for the OpenCL tests but I'm not sure what you mean with your first point. Can you specify what exactly you're seeing in your clean chroot build that seems to require that dependency on piglit? I'm building using clean chroots as well and I'm not encountering a problem and I'm also not aware of references to udev at all. (not seeing it when I search for it or in the build output either)
If it's needed for/by waffle, isn't that something to resolve there instead?

I will add that I haven't been able to build the waffle AUR package since last week or something so I had to do the build with waffle 1.6.2-1.
Beyond the change notification and automated build failure on my server I haven't checked the details yet but looks like dependencies changed and my not be correct there anymore.

Lone_Wolf commented on 2021-02-14 14:34

  • Building in a clean chroot showed systemd should be added to makedepends so camke can find libudev.pc (needed for waffle )

  • please enable PIGLIT_BUILD_CL_TESTS so opencl tests can be run. (This will require adding opencl-headers and ocl-icd to makedepends)