Package Details: pidgin-opensteamworks-git 1.6.1.r52.gbf7dd28-1

Git Clone URL: https://aur.archlinux.org/pidgin-opensteamworks-git.git (read-only, click to copy)
Package Base: pidgin-opensteamworks-git
Description: A plugin to connect to Steam Friends/Steam IM (purple plugin).
Upstream URL: https://github.com/EionRobb/pidgin-opensteamworks
Licenses: GPL3
Conflicts: pidgin-opensteamworks
Replaces: pidgin-opensteamworks-svn
Submitter: haagch
Maintainer: haagch (tinxy)
Last Packager: tinxy
Votes: 14
Popularity: 0.000015
First Submitted: 2015-09-04 06:48
Last Updated: 2016-04-20 12:02

Latest Comments

« First ‹ Previous 1 2

mkaito commented on 2014-03-28 14:02

Replace "svn" with "subversion" in makedepends.

mkaito commented on 2014-03-28 14:01

Missing subversion as makedepends.

roentgen commented on 2013-09-25 04:05

It's libgnome-keyring. It's already a dependency of another telepathy stuff so no big deal.

roentgen commented on 2013-09-25 04:00

It needs some gnome-keyring dependency. Would be nice to find out how to build without it.

==> Starting build()...
Package gnome-keyring-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gnome-keyring-1.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gnome-keyring-1' found
gcc -Wall -I. -g -O2 -fPIC -pipe steam_connection.c libsteam.c -o libsteam.so -ljson-glib-1.0 -lgio-2.0 -lgobject-2.0 -lpurple -lglib-2.0 -lssl3 -lsmime3 -lnss3 -lnssutil3 -lplds4 -lplc4 -lnspr4 -shared
In file included from steam_connection.h:5:0,
from steam_connection.c:3:
libsteam.h:9:18: fatal error: glib.h: No such file or directory
#include <glib.h>
^
compilation terminated.
In file included from libsteam.c:3:0:
libsteam.h:9:18: fatal error: glib.h: No such file or directory
#include <glib.h>
^
compilation terminated.
make: *** [libsteam.so] Error 1

onny commented on 2013-07-02 02:27

@haagch: Thank you for noticing, fixed it!

haagch commented on 2013-07-01 22:59

There's now a makefile upstream.

onny commented on 2013-06-16 09:27

@haagch: Thank you for the info, fixed it!

haagch commented on 2013-06-06 15:25

Needs nss pkgconfig in CFLAGS and/or LIBS now.