Package Details: picoscope 6.11.13_4r3-1

Git Clone URL: https://aur.archlinux.org/picoscope.git (read-only)
Package Base: picoscope
Description: gui for picotech oscilloscope
Upstream URL: http://www.picotech.com/linux.html
Licenses: custom
Submitter: abique
Maintainer: mti
Last Packager: mti
Votes: 6
Popularity: 0.507422
First Submitted: 2014-02-21 14:11
Last Updated: 2016-05-30 18:20

Dependencies (8)

Required by (0)

Sources (3)

Latest Comments

andrej commented on 2017-08-19 23:00

This just doesn't work; "No suitable device found.".
Are there any extra dependencies or kernel modules one needs to install?

EDIT: libps2000 does the trick in my case: https://aur.archlinux.org/packages/libps2000/ It's not a kernel module, it's some sort of a library that digs out the lowest-level USB devices from /dev.

atreides commented on 2017-01-05 21:54

I feel dpkg is unnecessary, I had success modifying PKGBUILD by removing dpkg dependency, 'noextract=()' and build() lines. Then adding 'tar -xvf data.tar.gz -C "${pkgdir}"'.

Same modification could be made to all picoscope related packages. Also 'webkit-sharp' instead of whole 'mono-tools' was enough dependency for me as well.

MacGyver commented on 2016-09-27 16:26

As far as I've been able to figure out, there's no actual dependency on mono-tools. mono-tools pulls in webkit-sharp, which in turn pulls in gtk-sharp-2. On my system, this is the only dependency I need to add when mono-tools is left out. Considering mono-tools pulls in half of gnome[1] in its tree, please consider trimming this dependency a bit.

[1] Yes, that's exaggeration, but still, I'd rather not pull in: art-sharp-2.24.2-4 gcr-3.20.0-1 gnome-mime-data-2.18.0-7 gnome-vfs-2.24.4-9 gnome-vfs-sharp-2.24.2-4 gvfs-1.28.2-1 libatasmart-0.19-3 libbonobo-2.32.1-4 libbonoboui-2.24.5-3 libgnome-2.32.1-6 libgnome-data-2.32.1-6 libgnome-sharp-2.24.2-4 libgnomecanvas-2.30.3-3 libgnomeui-2.24.5-2 libidl2-0.8.14-4 orbit2-2.14.19-3 udisks2-2.1.7-1 webkit-sharp-0.3-5 webkitgtk2-2.4.11-1

mcComBat commented on 2016-05-23 19:57

Please update to the latest version on the PicoScope repo (6.11.13-4r3)
It should fix the mono "IsMV Failed" problem.

Thanks!

rjs02 commented on 2016-03-27 12:51

Yeah I'm using the same version of mono as you. I got it working by removing the debconf dependency from libps4000a.deb, converting to pkg.tar and installing with pacman -U.

mti commented on 2016-03-27 12:36

Did you follow the recomendation to downgrade mono? The picoscope application does not work with the lastest version of mono. I use mono 4.0.4.1-1.

mcComBat commented on 2016-03-26 22:34

Hi' i'm trying to use this with 2206A, installed the libps2000a package, and for some reason PicoScope says it cant find my scope.
I've found some test tool provided in the libps2000a package (/opt/picoscope/share/doc/libps2000a/usbtest), and it does find my scope and says that everything is configured OK (udev rule working, and I am in pico group, which gives me access to the device).
Did anyone come across this problem?

rjs02 commented on 2016-02-27 16:00

libps4000a tarball? Somehow my 4824 device was working with the 2000a driver, but out of nowhere it stopped.

micah commented on 2015-12-23 19:51

You need to downgrade mono to 4.0.4 for this to work.

totalkrill commented on 2014-09-29 20:51

I must thank you for this :)

As thanks i added libps2000 and libps2000a

All comments