Package Details: piavpn-bin 2.9.0_06393-1

Git Clone URL: https://aur.archlinux.org/piavpn-bin.git (read-only, click to copy)
Package Base: piavpn-bin
Description: Private Internet Access client
Upstream URL: https://privateinternetaccess.com/
Keywords: vpn
Licenses: custom
Conflicts: pia-launch, pia-manager, pia-tools, private-internet-access-vpn
Provides: piavpn
Submitter: solstice
Maintainer: solstice
Last Packager: solstice
Votes: 7
Popularity: 1.05
First Submitted: 2020-04-14 15:32
Last Updated: 2021-05-12 08:30

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

yangsheng6810 commented on 2021-04-26 05:28

@solstice Could you change /etc/NetworkManager/conf.d/wgpia.conf into something like 50-wgpia.conf? wgpia.conf sets unmanaged-devices, which will overwrite all user customization of the same variable. Renaming it 50-wgpia.conf will allow the user to set in something like 90-unmanaged.conf to override (in my case, to merge my customization with wgpia.conf). Ideally, NetworkManager should merge the unmanaged-devices, but we cannot hope it could happen in the near future.

Doogie_MD commented on 2021-03-04 13:34

@olimazi Did you check the comments below? You will see

Don't forget to start and enable the systemd service with sudo systemctl enable --now piavpn.service

I would request that that be added to the output when program is installed because it's not clear that a service needs to be enabled upon install

olimazi commented on 2021-03-04 13:13

The package installed fine, however upon starting the client there are no settings options upon right click on the desktop icon, the only option is to double click the icon which immediately tries to "connect" to the VPN - it doesn't even ask me to enter my username/password credentials for my PIA account. The connection icon turns and never connects, this is where it's stuck.

solstice commented on 2020-12-10 22:47

@rwt13 yes previous version should have been named 2.6.0_05820 but I followed their scheme by simplicity/lazyness

rwt13 commented on 2020-12-10 19:23

-> piavpn-bin: local (2.6_05820-4) is newer than AUR (2.6.1_05824-1)

getting this when trying to update today

theriddick commented on 2020-10-20 02:11

I never had 2.5 installed so I've no idea what issues those were.

solstice commented on 2020-10-19 08:15

It seems PIA pull down their 2.5 release frm their download page, because of issues for some of their users.

such as yours @theriddick ?

I am downgrading the package to 2.4

theriddick commented on 2020-10-19 08:09

AccessDeniedAccess to PIA servers.

Changing package version to 2.4-05574 and updating the SHA256 resolved the problem for me.

Tio commented on 2020-09-12 12:38

Perfect. It works now. Thank you very much!

solstice commented on 2020-09-10 20:30

@Tio this is fixed in latest -4 package.

Don't forget to start and enable the systemd service with sudo systemctl enable --now piavpn.service