Package Details: php80 8.0.1-2

Git Clone URL: https://aur.archlinux.org/php80.git (read-only, click to copy)
Package Base: php80
Description: A general-purpose scripting language that is especially suited to web development
Upstream URL: https://www.php.net/
Licenses: PHP
Conflicts: php80-ldap
Provides: php80, php80-ldap=8.0.1
Replaces: php80-ldap
Submitter: muhviehstarr
Maintainer: muhviehstarr
Last Packager: muhviehstarr
Votes: 5
Popularity: 2.95
First Submitted: 2020-12-07 11:10
Last Updated: 2021-01-17 00:31

Sources (7)

Latest Comments

1 2 Next › Last »

snuffop commented on 2022-01-27 19:23

How do we pull the upstream into this build

LanceB98 commented on 2022-01-27 19:01

My builds are failing with

In file included from /home/[user]/.cache/yay/php80/src/php-8.0.1/ext/intl/breakiterator/breakiterator_class.cpp:21:
/home/lance/.cache/yay/php80/src/php-8.0.1/ext/intl/breakiterator/codepointiterator_internal.h:40:31: error: conflicting return type specified for ‘virtual UBool PHP::CodePointBreakIterator::operator==(const icu_70::BreakIterator&) const’
   40 |                 virtual UBool operator==(const BreakIterator& that) const;
      |                               ^~~~~~~~
In file included from /home/[user]/.cache/yay/php80/src/php-8.0.1/ext/intl/breakiterator/breakiterator_class.cpp:19:
/usr/include/unicode/brkiter.h:127:18: note: overridden function is ‘virtual bool icu_70::BreakIterator::operator==(const icu_70::BreakIterator&) const’
  127 |     virtual bool operator==(const BreakIterator&) const = 0;
      |                  ^~~~~~~~
make: *** [Makefile:1318: ext/intl/breakiterator/breakiterator_class.lo] Error 1
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: php80

It seems to be fixed upstream

el_aur commented on 2022-01-27 15:31

Hi guys. Wanna adopt this package. Have made universal builds for all PHP versions 5.3-8.1. Maintaining already php55, php72, php73, php74, php81 in AUR

muhviehstarr commented on 2021-01-17 00:32

@chindit thanks , i have added the deps

Gonzo2028 commented on 2021-01-16 18:18

works great now ;). Thank you!

chindit commented on 2020-12-31 09:05

@Gonzo2028 @muhviehstarr

Some dependencies are missing, that's why build fails.

You need to add «hspell, nuspell, libvoikko» to required dependencies in order for the package to build.

ItsYogSothoth commented on 2020-12-30 14:11

@Gonzo2028 @jvzr Check test log files at .../php80/src/php-8.0.0/Zend/tests for failing tests. In my case I found this output:

---- EXPECTED OUTPUT
===DONE===
---- ACTUAL OUTPUT
** (process:768017): WARNING **: 13:44:10.858: Error loading plugin: libhspell.so.0: cannot open shared object file: No such file or directory


** (process:768017): WARNING **: 13:44:10.858: Error loading plugin: libnuspell.so.4: cannot open shared object file: No such file or directory


** (process:768017): WARNING **: 13:44:10.858: Error loading plugin: libvoikko.so.1: cannot open shared object file: No such file or directory


** (process:768017): WARNING **: 13:44:10.925: Error loading plugin: libhspell.so.0: cannot open shared object file: No such file or directory


** (process:768017): WARNING **: 13:44:10.926: Error loading plugin: libnuspell.so.4: cannot open shared object file: No such file or directory


** (process:768017): WARNING **: 13:44:10.926: Error loading plugin: libvoikko.so.1: cannot open shared object file: No such file or directory

===DONE===
---- FAILED

After installing hspell nuspell libvoikko from repo the build and tests were successful

jvzr commented on 2020-12-29 17:50

I get the same error as @Gonzo2028 on my Linode server

muhviehstarr commented on 2020-12-27 18:46

@dfjigdfijgojio

fix your gpg config(keyserver)

basemax commented on 2020-12-25 18:13

:: There are 2 providers available for php80:
:: Repository AUR
    1) php80 2) php80-zts 

Enter a number (default=1): 1
 -> could not open file /var/lib/pacman/local/binutils-2.35-2/desc: No such file or directory
 -> could not open file /var/lib/pacman/local/bison-3.6.4-1/desc: No such file or directory
 -> could not open file /var/lib/pacman/local/fakeroot-1.24-2/desc: No such file or directory
 -> could not open file /var/lib/pacman/local/gcc-10.2.0-2/desc: No such file or directory
 -> could not open file /var/lib/pacman/local/gcc-libs-10.2.0-2/desc: No such file or directory
 -> could not open file /var/lib/pacman/local/git-2.28.0-1/desc: No such file or directory
 -> could not open file /var/lib/pacman/local/grep-3.4-1/desc: No such file or directory
 -> could not open file /var/lib/pacman/local/pacman-5.2.2-2/desc: No such file or directory
:: Checking for conflicts...
:: Checking for inner conflicts...
[Repo Make:10]  apr-1.7.0-3  apr-util-1.6.1-8  apache-2.4.46-3  aspell-0.60.8-2  c-client-2007f-11  tidy-5.7.16-2  unixodbc-2.3.9-1  tinycdb-0.78-4  postfix-3.5.8-3  freetds-1.2.12-1
[Aur:1]  php80-8.0.0-1

==> Remove make dependencies after install? [y/N] n
:: Downloaded PKGBUILD (1/1): php80
  1 php80                                    (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> n
:: (1/1) Parsing SRCINFO: php80

:: PGP keys need importing:
 -> CBAF69F173A0FEA4B537F470D66C9593118BCCB6, required by: php80
 -> 1729F83938DA44E27BA0F4D3DBDB397470D12172, required by: php80
 -> F38252826ACD957EF380D39F2F7956BC5DA04B5D, required by: php80
==> Import? [Y/n] y
:: Importing keys with gpg...
gpg: keyserver receive failed: General error
problem importing keys