Package Details: php73-sodium 7.3.23-1

Git Clone URL: https://aur.archlinux.org/php73.git (read-only, click to copy)
Package Base: php73
Description: sodium module for PHP
Upstream URL: https://www.php.net/
Licenses: PHP
Submitter: matth
Maintainer: matth
Last Packager: matth
Votes: 8
Popularity: 1.23
First Submitted: 2019-12-24 17:08
Last Updated: 2020-10-08 18:01

Latest Comments

1 2 3 Next › Last »

TheGoliath commented on 2020-05-02 15:48

Package also provides the php package itself. Should be added to the provides section

cdo commented on 2020-04-19 19:42

Thanks for this package. It builds perfectly fine on armv7h. Do you mind adding this architecture to the PKGBUILD?

berturion commented on 2020-03-09 09:51

Thank you @tompear, it is solved after rebuild.

tompear commented on 2020-03-09 07:18

Just rebuild php73-imagick. In most cases it will resolve the problem.

berturion commented on 2020-03-08 16:07

Just to let you know, since version upgrade of ImageMagick in the arch repo, I have this warning :

PHP Warning:  Version warning: Imagick was compiled against ImageMagick version 1801 but version 1802 is loaded. Imagick will run but may behave surprisingly
extra/imagemagick                    7.0.9.27-1        7.0.10.0-1

berturion commented on 2020-03-03 11:08

Ok, thank you @tompear, I did not understand, it is clear now :)

tompear commented on 2020-03-03 07:38

Once again, 'smtp-forwarder' in case of install will give you a choice what package to install: esmtp, exim, msmtp-mta, nullmailer, opensmtpd or postfix. Any of it will fill the dependency so PKGBUILD must not point directly to postfix nor exim.

So all you need to do is clone package repo, edit PKGBUILD and change postfix to whatever you want and run makepkg -si.

berturion commented on 2020-03-02 10:32

@tompear about postfix dependency, I had to replace my existing exim installation with postfix in order to install php73. My problem is solved because my installation is very simple but that could cause some problem for others that don't have the choice of keeping exim (configuration of such a software is quiet difficult). Is it possible to accept exim as the mailer dependency?

tompear commented on 2020-03-02 08:27

@takit php73 doesnt depends directly on mariadb-libs but postfix (as php73 dependency) does. In fact postfix can by replaced by smtp-forwarder. There are some packages providing this functionality to choose from. I am using nullmailer.

tompear commented on 2020-02-28 14:45

PHP 7.3.15 released.