Package Details: php72-xsl 7.2.34-10

Git Clone URL: https://aur.archlinux.org/php72.git (read-only, click to copy)
Package Base: php72
Description: xsl module for php72
Upstream URL: http://www.php.net
Keywords: 7.2 php php7
Licenses: PHP
Submitter: el_aur
Maintainer: el_aur
Last Packager: el_aur
Votes: 9
Popularity: 0.000011
First Submitted: 2019-01-31 20:58
Last Updated: 2022-01-27 12:22

Dependencies (52)

Required by (0)

Sources (17)

Latest Comments

1 2 3 4 5 6 Next › Last »

el_aur commented on 2022-01-27 12:11

Read Carefully! Breaking changes in compare with native PHP package

  1. Console version /usr/bin/php72 is installed with php72-cli subpackage, php72 doesn't include it anymore!!!

  2. PEAR and PECL are available as php72-pear and php72-pecl subpackages

  3. All shared modules are respresented as stand-alone subpackages and are not included with php72 package anymore.

  4. No more extensions in php.ini itself!

Separate INI files for each extension are placed in /etc/php72/conf.d

They are loaded in correct order according to priority

el_aur commented on 2022-01-27 12:10

@miguelmsoler thanks for nice idea, will update packages soon

miguelmsoler commented on 2022-01-26 19:29

@el_aur better than that, you can change that line to:

sapi/cli/php -n -r 'echo ini_get("sendmail_path");' | grep -q `which sendmail`

The error was caused because sendmail was in /usr/sbin/ instead of /usr/bin

I think that changing that line would fix the issue for everyone as long as "which" returns the path for sendmail.

Thank you for highlighting the line that caused the problem.

Thank you for

el_aur commented on 2022-01-26 17:12

@miguelmsoler can you try with removing

 sapi/cli/php -n -r 'echo ini_get("sendmail_path");' | grep -q '/usr/bin/sendmail'

line

miguelmsoler commented on 2022-01-26 16:54

I could not install php72:

==> Starting check()...
~/.cache/aurutils/sync/php72/src/build-cli ~/.cache/aurutils/sync/php72/src
==> ERROR: A failure occurred in check().
    Aborting...

wgomg commented on 2022-01-24 20:03

@el_aur everything working ok now, thank you!

el_aur commented on 2022-01-24 19:37

@wgomg updated package, try to rebuild now

wgomg commented on 2022-01-24 15:03

Thank you @el_aur , installed now and problem fixed, but now having problems with php72-mysql, php72-openssl not found.

el_aur commented on 2022-01-24 10:27

@wgomg: have you installed php72-cli subpackage?

wgomg commented on 2022-01-21 21:51

/usr/bin/php72 is not being installed

$ whereis php72 
php72: /usr/lib/php72 /etc/php72 /usr/include/php72