Package Details: php72-phpdbg 7.2.34-2

Git Clone URL: https://aur.archlinux.org/php72.git (read-only, click to copy)
Package Base: php72
Description: Interactive PHP debugger
Upstream URL: http://www.php.net
Keywords: 7.2 php
Licenses: PHP
Provides: php-phpdbg=7.2.34
Submitter: el_aur
Maintainer: el_aur
Last Packager: el_aur
Votes: 9
Popularity: 0.008713
First Submitted: 2019-01-31 20:58
Last Updated: 2020-12-28 21:16

Latest Comments

1 2 3 4 5 Next › Last »

el_aur commented on 2021-01-15 10:18

@Anagastes: Build is fine, check your icu library version

[el@archbox php72]$ ldd /usr/lib/php72/modules/intl.so | grep icu
    libicuio.so.68 => /usr/lib/libicuio.so.68 (0x00007fa850fc3000)
    libicui18n.so.68 => /usr/lib/libicui18n.so.68 (0x00007fa850ca4000)
    libicuuc.so.68 => /usr/lib/libicuuc.so.68 (0x00007fa850ab5000)
    libicudata.so.68 => /usr/lib/libicudata.so.68 (0x00007fa84ef74000)
[el@archbox php72]$ pacman -Qo /usr/lib/libicudata.so.68
/usr/lib/libicudata.so.68 is owned by icu 68.2-1

Latest php72 version is to be built with icu 68.2, but not with earlier version!

So just upgrade system before building php72 ;)

Anagastes commented on 2021-01-14 13:53

Cant compile latest version

/home/andre/.cache/yay/php72/src/php-7.2.34/ext/intl/collator/collator_sort.c: In Funktion »zif_collator_sort«:
/home/andre/.cache/yay/php72/src/php-7.2.34/ext/intl/collator/collator_sort.c:349:26: Fehler: »true« nicht deklariert (erste Verwendung in dieser Funktion)
  349 |  collator_sort_internal( true, INTERNAL_FUNCTION_PARAM_PASSTHRU );
      |                          ^~~~
/home/andre/.cache/yay/php72/src/php-7.2.34/ext/intl/collator/collator_sort.c:349:26: Anmerkung: jeder nicht deklarierte Bezeichner wird nur einmal für jede Funktion, in der er vorkommt, gemeldet
/home/andre/.cache/yay/php72/src/php-7.2.34/ext/intl/collator/collator_sort.c: In Funktion »zif_collator_asort«:
/home/andre/.cache/yay/php72/src/php-7.2.34/ext/intl/collator/collator_sort.c:543:26: Fehler: »false« nicht deklariert (erste Verwendung in dieser Funktion)
  543 |  collator_sort_internal( false, INTERNAL_FUNCTION_PARAM_PASSTHRU );
      |                          ^~~~~
make: *** [Makefile:1146: ext/intl/collator/collator_sort.lo] Fehler 1
make: *** Es wird auf noch nicht beendete Prozesse gewartet....
==> FEHLER: Ein Fehler geschah in build().
    Breche ab...
error making: php72

el_aur commented on 2020-12-28 21:16

Updated with new version. Took solution from

https://759352.bugs.gentoo.org/attachment.cgi?id=677674

Related to icu library update

el_aur commented on 2020-12-28 21:11

@messju getting error while building intl:

/home/el/_aur/php72/src/php-7.2.34/ext/intl/collator/collator_sort.c: In function ‘zif_collator_sort’:
/home/el/_aur/php72/src/php-7.2.34/ext/intl/collator/collator_sort.c:349:26: error: ‘TRUE’ undeclared (first use in this function)
  349 |  collator_sort_internal( TRUE, INTERNAL_FUNCTION_PARAM_PASSTHRU );
      |                          ^~~~
/home/el/_aur/php72/src/php-7.2.34/ext/intl/collator/collator_sort.c:349:26: note: each undeclared identifier is reported only once for each function it appears in
/home/el/_aur/php72/src/php-7.2.34/ext/intl/collator/collator_sort.c: In function ‘zif_collator_asort’:
/home/el/_aur/php72/src/php-7.2.34/ext/intl/collator/collator_sort.c:543:26: error: ‘FALSE’ undeclared (first use in this function)
  543 |  collator_sort_internal( FALSE, INTERNAL_FUNCTION_PARAM_PASSTHRU );
      |                          ^~~~~
make: *** [Makefile:1146: ext/intl/collator/collator_sort.lo] Error 1
==> ERROR: A failure occurred in build().
    Aborting...

el_aur commented on 2020-12-28 19:52

updated to 7.2.34. Thanks @messju

messju commented on 2020-11-11 16:27

There was a new release on October 1st. I did this to upgrade:

diff --git a/PKGBUILD b/PKGBUILD
index 8dbbee8..68def49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _pkgbase=${pkgbase%72}
 _realpkg=${pkgbase%}
 pkgname=("${pkgbase}"
          "${_realpkg}-"{cgi,apache,fpm,embed,phpdbg,dblib,enchant,gd,imap,intl,odbc,pgsql,pspell,snmp,sqlite,tidy,xsl,sodium}"")
-pkgver=7.2.33
+pkgver=7.2.34
 pkgrel=1
 pkgdesc="php 7.2 compiled as to not conflict with mainline php"
 arch=('i686' 'x86_64')
@@ -349,7 +349,7 @@ package_php72-sodium() {
     depends=("${pkgbase}" 'libsodium')
     install -D -m755 ${srcdir}/build/modules/sodium.so ${pkgdir}/usr/lib/${_realpkg}/modules/sodium.so
 }
-md5sums=('8921fa6824dee6f261a3c832a43ea6ac'
+md5sums=('adb64072b9b7e4634844a72512239a34'
          '13cda50a6a420d04ddc26935ded3164e'
          'b7d69762f7c045b3950d770e04db504c'
          'f248c783449f310291905b5551c57e48'

GramachoGuy commented on 2020-07-15 20:44

How to install the pdo_firebird extension for php 7.2?

meister1337 commented on 2020-06-17 09:40

@el_aur thanks, the rebuild of php72 and php72-xsl fixed it.

el_aur commented on 2020-06-17 09:00

@meister1337 also don't forget to make pacman -Syu before building php72 to get latest versions of packages

el_aur commented on 2020-06-17 08:51

@meister1337 your error says that library icu was updated to new version. Just rebuild php72 package from AUR and install it again :)