Package Details: php71-dblib 7.1.33-1

Git Clone URL: https://aur.archlinux.org/php71.git (read-only, click to copy)
Package Base: php71
Description: dblib module for PHP
Upstream URL: http://www.php.net
Keywords: 7.1 php
Licenses: PHP
Provides: php71-dblib=7.1.33
Submitter: Synthead
Maintainer: wget
Last Packager: wget
Votes: 10
Popularity: 0.000000
First Submitted: 2018-03-26 18:04
Last Updated: 2019-11-03 19:03

Pinned Comments

wget commented on 2019-02-11 11:49

This package makes use of GPG keys for integrity verification. Here are the PGP keys you need to import (if you trust them):

$ gpg --recv-keys A917B1ECDA84AEC2B568FED6F50ABC807BD5DCD0 528995BFEDFBA7191D46839EF9BA0ADA31CBD89E 1729F83938DA44E27BA0F4D3DBDB397470D12172

Receiving GPG keys might fail with the following error message: $ gpg: keyserver receive failed: Connection refused. If this happens, just check your DNS or use other ones.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

el_aur commented on 2022-01-27 16:29

Hi guys. Wanna adopt this package. Have made universal builds for all PHP versions 5.3-8.1. Maintaining already php55, php72, php73, php74, php81 in AUR

el_aur commented on 2022-01-25 14:34

Have ported cve patches and Debian patches, can share here if you make me comaintainer :)

kingbeencent commented on 2022-01-11 07:04

Hello! It took me like 4 hours resolving the way we can compile this with icu70 error.

First of all we need to fill the following pre-requisites:

  1. Download and extract (in a path-friendly folder) the following ICU package Version: 67.1
  2. Clone this repo in a user-friendly folder.
  3. Install icu67 from yay. (Not icu67-bin that's not gonna work)

Now just follow the steps below:

  1. Get into the cloned folder and execute: makepkg -si and let the compilation fails successfully.
  2. Copy and paste the produced configure file from src/php-7.1.33/configure into the root folder path. (So we must have php71/configure)
  3. Now, replace the following line section in your php71/configure: ICU_CONFIG="$PHP_ICU_DIR/bin/icu-config" (Line: 45292), with: ICU_CONFIG="$PHP_ICU_DIR/bin/icu-config --prefix=/{path to file from step 1}/icu/usr/local/
  4. Add the lines mentioned by @shawe in the very beginning of build() method in PKGBUILD.
    export CC="gcc -DTRUE=1 -DFALSE=0"
    export CXX="g++ -DTRUE=1 -DFALSE=0"
  1. Now before ln -s ../${_pkgbase}-${pkgver}/configure add the following line echo "$(cat ../../configure)" > ../${_pkgbase}-${pkgver}/configure in PKGBUILD file. Also you must add the following flag in the ./configure command from this same section (and just before ${phpExtensions}): --with-icu-dir=/{path to file from step 1}/icu/usr/local \
  2. Then remove the previous failed build data with rm -rf src/build.
  3. Finally do makepkg -si again, and all set! It should compile now.

I hope it wokrs, I'll be keeping an eye during the next month in order to answer questions and help with the process! In my case I cannot make php71 the default one version, I need multiple versions at the same time, so I needed a way to install it with its suffix

oislone commented on 2022-01-07 08:59

I have been failing to install PHP71, but Searched archwiki and found https://wiki.archlinux.org/title/Arch_Linux_Archive#How_to_restore_all_packages_to_a_specific_date

  1. replacing your /etc/pacman.d/mirrorlist with the following content:

Server=https://archive.archlinux.org/repos/2018/03/30/$repo/os/$arch

And mark other Server settings.

  1. yay -Syy

  2. yay php

yay php-intl ......

The update was successful and returned to php7.1.3 without any problems. Then restore the modified mirrorlist to the original setting,

Then add /etc/pacman.conf IgnorePkg = php php-intl php-gd php-fpm php-apache

You need to follow the php extension settings you installed. After a full update, it will not update to the new version of php

wgomg commented on 2022-01-06 14:07

I'm having the same issue with icu version.

cizin commented on 2021-12-19 07:18

package is broken due to incompatibility with icu >= 70. Does anyone know how to fix it?

df8oe commented on 2021-09-16 06:23

New issue pops up (also for php70): GD_FLIP_VERTICAL, GD_FLIP_HORINZONTAL, GD_FLIP_BOTH not declared... How can this be fixed?

pgoetz commented on 2021-07-01 00:13

When I try to run

yay -S php71-mcrypt

I get the following error:

 enchant-2.2.15-4-x86_64.pkg.tar.zst failed to download
 Total ( 1/10)                     7.3 MiB  43.2 MiB/s 00:00 [################################] 100%
error: failed retrieving file 'enchant-2.2.15-4-x86_64.pkg.tar.zst' from mirrors.kernel.org : The requested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (failed to retrieve some files)
Errors occurred, no packages were upgraded.

shawe commented on 2021-02-12 12:31

I confirm solution by @reibeku it's working:

Replace:

build() {
    local phpConfig="\
        --srcdir=../${_pkgbase}-${pkgver} \
        --config-cache \

With:

build() {
        export CC="gcc -DTRUE=1 -DFALSE=0"
        export CXX="g++ -DTRUE=1 -DFALSE=0"
    local phpConfig="\
        --srcdir=../${_pkgbase}-${pkgver} \
        --config-cache \

reibeku commented on 2021-02-10 10:31

Please find the solution of error: ‘TRUE’ undeclared here: https://bbs.archlinux.org/viewtopic.php?pid=1955066#p1955066