Package Details: php-phpiredis-git 1.0.1.r4.g4afea21-1

Git Clone URL: https://aur.archlinux.org/php-phpiredis-git.git (read-only, click to copy)
Package Base: php-phpiredis-git
Description: PHP extension for Redis based on Hiredis
Upstream URL: https://github.com/nrk/phpiredis
Keywords: hiredis php redis
Licenses: PHP
Submitter: user00265
Maintainer: User
Last Packager: User
Votes: 0
Popularity: 0.000000
First Submitted: 2018-10-26 14:50
Last Updated: 2020-09-21 11:38

Latest Comments

keithspg commented on 2020-09-20 14:11

nrk has now fixed phpiredis. The current version is hiredis in Arch is 1.0. To build a functional php-phpiredis extension, you need to change 2 lines of the PKGBUILD: url='https://github.com/nrk/phpiredis' source=('git+https://github.com/nrk/phpiredis.git#branch=v1.1') the built git has pkgver=1.0.1.r4.g4afea21 This works with hiredis 1.0 this could probably be worked into a release version using the v1.0.1 release of nrk's git, but that is up to the maintainer.

keithspg commented on 2020-03-28 18:54

This package fails to build a use-able extension because the repository https://github.com/nrk/phpiredis has not kept up with hiredis. Hiredis 0.13 works and will allow this AUR to build a functional extension, but the current Arch hiredis package is 0.14 and the resulting package will not work with the current php version. There has been a naming change in the hiredis functions between 0.13 and 0.14. I could supply a patch to make it work if needed and have supplied the repository with a pull request that fixes it for 0.14 but it has not been accepted nor has there been any development for a few years. Basically, we need to change references to redisReplyReader to redisReader

keithspg commented on 2019-03-31 20:35

this builds and installs/works for armv6h and armv7h (raspberry pi B+/Zero/2/3