Package Details: php-cs-fixer 2.16.3-1

Git Clone URL: https://aur.archlinux.org/php-cs-fixer.git (read-only, click to copy)
Package Base: php-cs-fixer
Description: Analyzes some PHP source code and tries to fix coding standards issues (PSR-1 and PSR-2 compatible).
Upstream URL: http://cs.sensiolabs.org/
Keywords: php
Licenses: MIT
Submitter: bgaleotti
Maintainer: bgaleotti (sanduhrs)
Last Packager: bgaleotti
Votes: 24
Popularity: 0.000007
First Submitted: 2012-08-10 16:53
Last Updated: 2020-05-03 14:54

Dependencies (5)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

sanduhrs commented on 2015-08-12 17:14

@bgaleotti package is broken after you removed lin 19 from the pgkbuild.
See https://aur.archlinux.org/cgit/aur.git/diff/?h=php-cs-fixer&context=3&ignorews=0&dt=1#n19

And please have a look at https://github.com/sanduhrs/arch-aur-php-cs-fixer
which contains a working pkgbuild including a message about the required settings.

regards.

trichards commented on 2015-08-12 16:05

Building 1.10-1 fails with an error from box:

==> Starting build()...

<snip>

[RuntimeException]
The tag or commit hash could not be retrieved from "/tmp/build/php-cs-fixer/src/PHP-CS-Fixer-1.10": fatal: Not a git repository (or any parent up to mount point /tmp)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).

Complete output: https://gist.github.com/t-richards/922bf6331788521565b1

sanduhrs commented on 2015-08-10 15:17

Update to 1.10: https://github.com/sanduhrs/arch-aur-php-cs-fixer

sanduhrs commented on 2015-07-21 16:03

Add an install hokk to inform people of the requirements: https://github.com/sanduhrs/arch-aur-php-cs-fixer

sanduhrs commented on 2015-07-20 10:51

Update to 1.10 and install hook to inform user of ini requirements: https://github.com/sanduhrs/arch-aur-php-cs-fixer

Stephen304 commented on 2015-06-11 21:27

Turns out I had to set these in my php.ini
extension=phar.so
phar.readonly = Off

Stephen304 commented on 2015-06-11 21:25

Turns out I had to uncomment extension=phar.so in my php.ini.

Stephen304 commented on 2015-06-11 20:59

I'm getting this error on build:

==> Starting build()...
Loading composer repositories with package information
Installing dependencies from lock file
Nothing to install or update
Generating autoload files

[InvalidArgumentException]
Command "build" is not defined.

==> ERROR: A failure occurred in build().
Aborting...
The build failed.


Any idea?

falmp commented on 2014-05-12 15:53

Please update to move the .phar file to /usr/share/webapps/bin.

You can use this PKGBUILD as template: https://aur.archlinux.org/packages/phpbrew-git/

jamek commented on 2014-04-05 10:29

The new value of md5 sum: 501733ff21110855b7edb44bda998800