Package Details: php-cs-fixer 2.16.3-1

Git Clone URL: (read-only, click to copy)
Package Base: php-cs-fixer
Description: Analyzes some PHP source code and tries to fix coding standards issues (PSR-1 and PSR-2 compatible).
Upstream URL:
Keywords: php
Licenses: MIT
Submitter: bgaleotti
Maintainer: bgaleotti (sanduhrs)
Last Packager: bgaleotti
Votes: 24
Popularity: 0.000001
First Submitted: 2012-08-10 16:53
Last Updated: 2020-05-03 14:54

Dependencies (5)

Required by (0)

Sources (1)

Latest Comments

1 2 3 4 Next › Last »

Magotchi commented on 2020-05-01 14:20

This is not necessarily a package bug, as it may well be a pikaur bug, but does anybody know why, when I build this package in pikaur, it tries to use sudo right after the "Updating dependencies" step, as follows?:

==> Validating source files with md5sums...
    php-cs-fixer ... Skipped
==> Extracting sources...
  -> Creating working copy of php-cs-fixer git repo...
Cloning into 'php-cs-fixer'...
Switched to a new branch 'makepkg'
==> Starting build()...
Loading composer repositories with package information
Updating dependencies
[sudo] password for ...:

This does not happen if I freshly clone it and use makepkg.

Edit: It also does not happen in "yay". I guess I'll figure it out and give pikaur a report.

Edit: Hmm. Now when I try it again in pikaur, I can't reproduce it. Weird. This happens to me every time this package needs to update.

hriad commented on 2019-01-13 07:18

Thanks for the diff @danger89

danger89 commented on 2019-01-05 01:50

Yes, Finally we have v2.14.0 Sunrise, supporting 7.3 now officially. Diff for pkgbuild:

diff --git a/PKGBUILD b/PKGBUILD
index 05acdbe..042304d 100644
@@ -3,13 +3,13 @@

 pkgdesc="Analyzes some PHP source code and tries to fix coding standards issues (PSR-1 and PSR-2 compatible)."
-depends=("php>=5.6" "php<7.3")
+depends=("php>=5.6" "php>=7")
 makedepends=("php-box" "php-composer" "git")

macfly commented on 2018-03-01 15:44

Thanks for your quick update

sanduhrs commented on 2018-03-01 11:57

@macfly that went in by mistake, should have been <7.3 as seen in the composer.json file: Thanks for reporting!

macfly commented on 2018-03-01 09:32

Why do you require php under version 7.2 ? I've just remove it from the PKGBUILD and it seems ok.

Also on sensiolabs site they say: "PHP needs to be a minimum version of PHP 5.6.0." But not incompatibility with php version 7.2

supermario commented on 2016-02-13 19:20

license needs to be an array now. Can you please update the PKGBUILD?


sanduhrs commented on 2016-01-15 11:33

Fixed the problems, current package should work fine.

soyel commented on 2016-01-04 04:55

@sanduhrs PHP in extra is now PHP 7. It causes several problems with the installation of this package with a default PHP install.

* Phar is now bundled inside PHP (See Arch PHP maintainer blog :
* "open_basedir" is now commented by default (that means no open_basedir in effect).

==> Starting check()...
Warning: You must add ':/usr/' to 'open_basedir' setting in your php.ini to use php-cs-fixer
==> ERROR: Makepkg was unable to build php-cs-fixer.

Got rid of the whole "check()" function and few "-d" inside the "build()" function made the package installation successful.

sanduhrs commented on 2015-12-21 15:02

Updated the package to inform the user of the runtime requirements.