Package Details: php-box 2.7.5-1

Git Clone URL: https://aur.archlinux.org/php-box.git (read-only, click to copy)
Package Base: php-box
Description: An application for building and managing Phars
Upstream URL: https://github.com/box-project/box2
Licenses: MIT
Submitter: jojosch
Maintainer: sanduhrs
Last Packager: sanduhrs
Votes: 36
Popularity: 0.000782
First Submitted: 2013-07-29 14:12
Last Updated: 2019-12-13 19:16

Latest Comments

« First ‹ Previous 1 2 3

Stephen304 commented on 2015-06-11 21:31

Just a note for people using this as a dependency, in order to use the build command, you have to set these options in the php.ini (coming from a clean automated install via packer)

extension=phar.so
phar.readonly = Off

Really threw me for a loop when I tried to install php-cs-fixer and packer tried to install php, php-box, then php-cs-fixer and failed because the default config doesn't work.

rdoursenaud commented on 2015-02-06 14:52

Sorry for my previous comment.
I made a fool of myself.

rdoursenaud commented on 2015-02-06 14:50

The LICENSE file checksums are wrong.
Here are the right ones:
md5 5418dc5ccc29538a467fabb815bbd757
sha256 ba2dfc30b9659262549c839894838d9a1fe78ca533d0338cebc2f4f634b3bb12

You don't need both BTW. sha256 should be enough.

jojosch commented on 2014-03-03 19:14

@r1pp3rj4ck thanks for the patch :)

r1pp3rj4ck commented on 2014-03-03 19:00

jojosch, here is a little patch I wrote: https://gist.githubusercontent.com/r1pp3rj4ck/9331951/raw/2bdbed43a972302f9f159f9b8ac1fa10d5c8d192/PKGBUILD.patch

After applying this patch:
a) you can actually use the proper version
b) it will work with the default open_basedir config

Please update!