Package Details: photoqt 1.7.1-14

Git Clone URL: https://aur.archlinux.org/photoqt.git (read-only, click to copy)
Package Base: photoqt
Description: Fast and highly configurable image viewer with a simple and nice interface.
Upstream URL: http://photoqt.org/
Licenses: GPL2
Submitter: archtux
Maintainer: luspi
Last Packager: luspi
Votes: 92
Popularity: 0.053843
First Submitted: 2013-08-11 21:50
Last Updated: 2020-03-12 05:25

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

zw3n commented on 2015-08-10 21:37

Receiving "qrc:/qml/mainwindow.qml:9:1: module "QtQuick.Dialogs" is not installed" when trying to start.

"qt5-quickcontrols" should be added as a dependency to fix this.

luspi commented on 2015-03-07 00:49

"photoqt: error while loading shared libraries: libGraphicsMagick++.so.3: cannot open shared object file: No such file or directory"

Needs re-install to work with updated GraphicsMagick...

linuxchick commented on 2015-01-20 19:17

installed no problem on my first machine, then on a different pc, fresh install of Arch, it failed, with this error "CMake Error at /usr/lib64/cmake/Qt5Core/Qt5CoreMacros.cmake:275 (message):
Can not use "Svg" module which has not yet been found."
Installing qt5-svg fixed it.

314eter commented on 2014-10-13 21:46

I got a cmake error because it couldn't find Qt5LinguistTools. Adding qt5-tools to makedepends solved the problem.

willemw commented on 2014-10-13 18:07

Please add exiv2 and graphicsmagick (, etc?) to 'depends' and to 'cmake'. They seem to provide very useful features to have by default. Your comment about "wiki of packaging standards" does not mean that by default the program must be a minimal program. See for example packages vim and vim-minimal.

/usr in the .install file should not have a leading / (see https://wiki.archlinux.org/index.php/GNOME_Package_Guidelines).

willemw commented on 2014-10-13 17:29

Please add exiv2 and graphicsmagick (, etc?) to 'depends' and to 'cmake'. They seem very useful features to have by default. Your comment about "wiki of packaging standards" does not mean that by default the program must be a minimal program. See for example packages vim and vim-minimal.

/usr in the .install file should not have a leading / (see https://wiki.archlinux.org/index.php/GNOME_Package_Guidelines).

Anonymous comment on 2013-08-15 14:34

@archtux
Okay, thanks a million! There's something new to learn everyday :)

archtux commented on 2013-08-15 12:21

@irishtux
I disabled those dependencies at building because the packaging standards of Arch
require the least dependencies to be included for a package to work.
If you don't have those optional dependencies installed, it won't compile.
That's the reason it was disabled in the configure phase.
If you read the wiki of packaging standards:
Any optional dependencies that are not needed to run the package or have it generally function should not be included; instead the information should be added to the optdepends array.
I'm going to modify the PKGBUILD for people who want to install the FULL program.

Anonymous comment on 2013-08-15 11:35

Is there a reason why graphicsmagick, phonon, exiv2 are disabled??

archtux commented on 2013-08-11 21:57

Program has been renamed -> 'photoqt'.(https://aur.archlinux.org/packages/photoqt/)