Package Details: photivo-hg 1124+.41a1d55bb275+-1

Git Clone URL: https://aur.archlinux.org/photivo-hg.git (read-only, click to copy)
Package Base: photivo-hg
Description: Free and open source photo processor
Upstream URL: http://photivo.org/
Licenses: GPL3
Conflicts: photivo
Provides: photivo
Submitter: stativ
Maintainer: stativ
Last Packager: stativ
Votes: 41
Popularity: 0.000004
First Submitted: 2010-10-30 10:09
Last Updated: 2018-04-01 15:03

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

Anonymous comment on 2012-06-24 05:12

stativ:
After exposing the problem in photivo forum on flickr, the author solved the problem.

stativ commented on 2012-05-26 11:54

It works fine here. I'm sure it was just a temporary breakage.

You must reckon with occasional breakages when dealing with development versions of software.

Anonymous comment on 2012-05-21 18:06

I'm unable to compile:
../Sources/ptDcRaw.cpp: En la función miembro ‘void ptDcRaw::parse_redcine()’:
../Sources/ptDcRaw.cpp:6320:30: aviso: comparación entre expresiones enteras signed y unsigned [-Wsign-compare]
../Sources/ptDcRaw.cpp: En la función miembro ‘void ptDcRaw::tiff_head(tiff_hdr*)’:
../Sources/ptDcRaw.cpp:8215:21: error: no se puede encontrar un operador literal de cadena ‘operator"" DCRAW_VERSION’
make[1]: *** [../Objects/ptDcRaw.o] Error 1
make[1]: se sale del directorio `/tmp/yaourt-tmp-rafa/aur-photivo-hg/src/photivo-build/photivoProject'
make: *** [sub-photivoProject-make_default] Error 2

I installed dcraw, but not resolv the problem

stativ commented on 2012-05-03 14:15

thomasba: I'm pretty sure you are wrong, photivo doesn't depend on any specific version of libpng or libtiff. Maybe you didn't recompile graphicsmagick-qd16 with the new libpng/libtiff, as this may cause the issues you are seeing.

Anonymous comment on 2012-04-28 17:44

Had to install libpng14 and libtiff3... Otherwise this error occurs:
linking ../photivo
/usr/bin/ld: cannot find -lpng14

stativ commented on 2012-04-27 16:36

Littlepaul476: strange, I don't have any of these installed and it works.

Anonymous comment on 2012-04-27 15:17

version 787 also have these dependencies (from AUR):
libpng14
libtiff3

stativ commented on 2012-04-26 16:19

morgulbrut: see http://code.google.com/p/photivo/issues/detail?id=72

Anonymous comment on 2012-04-24 17:36

I'm unable to compile:

compiling ../Sources/qtsingleapplication/qtlocalpeer.cpp
../Sources/qtsingleapplication/qtlocalpeer.cpp: In Konstruktor »QtLocalPeer::QtLocalPeer(QObject*, const QString&)«:
../Sources/qtsingleapplication/qtlocalpeer.cpp:96:54: Fehler: »::getuid« wurde nicht deklariert
../Sources/qtsingleapplication/qtlocalpeer.cpp:96:54: Anmerkung: empfohlene Alternative:
In file included from ../Sources/qtsingleapplication/qtlockedfile_unix.cpp:42:0,
from ../Sources/qtsingleapplication/qtlocalpeer.cpp:60:
/usr/include/unistd.h:698:16: Anmerkung: »QtLP_Private::getuid«
make[1]: *** [../Objects/qtlocalpeer.o] Fehler 1

do I need some qtlibs?
make[1]: Leaving directory `/tmp/yaourt-tmp-t800/aur-photivo-hg/src/photivo-build/photivoProject'
make: *** [sub-photivoProject-make_default] Fehler 2

Anonymous comment on 2012-02-07 15:07

Thanks sajmmiller. I resolved that issue follow your procedure. :)
I have download the previous package from http://arm.konnichi.com/2012/02/02/extra/os/x86_64/ :
mercurial-2.0.2-1-x86_64.pkg.tar.xz
mercurial-2.0.2-1-x86_64.pkg.tar.xz.sig
$ sudo pacman -U mercurial-2.0.2-1-x86_64.pkg.tar.xz

Note:
This is the first time that i made a downgrade so i write here the procedure because i think perhaps could be helpful even for others people.